summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/weechat/weechat-9999.ebuild')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index b33c433ae6d2..9612d0567f73 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -3,9 +3,10 @@
EAPI=7
+LUA_COMPAT=( lua5-{1..4} )
PYTHON_COMPAT=( python3_{7..9} )
-inherit cmake python-single-r1 xdg-utils
+inherit cmake lua-single python-single-r1 xdg-utils
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
@@ -29,6 +30,7 @@ LANGS=" cs de es fr it ja pl ru"
IUSE="doc man nls test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
test? ( nls )
"
@@ -41,7 +43,7 @@ RDEPEND="
net-misc/curl[ssl]
charset? ( virtual/libiconv )
guile? ( >=dev-scheme/guile-2.0 )
- lua? ( dev-lang/lua:0 )
+ lua? ( ${LUA_DEPS} )
nls? ( virtual/libintl )
perl? ( dev-lang/perl:= )
php? ( >=dev-lang/php-7.0:*[embed] )
@@ -62,11 +64,16 @@ BDEPEND="
nls? ( >=sys-devel/gettext-0.15 )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0-cmake_lua_version.patch
+)
+
DOCS="AUTHORS.adoc ChangeLog.adoc Contributing.adoc ReleaseNotes.adoc README.adoc"
RESTRICT="!test? ( test )"
pkg_setup() {
+ use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
}