summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gnutls/gnutls-3.5.15.ebuild')
-rw-r--r--net-libs/gnutls/gnutls-3.5.15.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-libs/gnutls/gnutls-3.5.15.ebuild b/net-libs/gnutls/gnutls-3.5.15.ebuild
index 78dd42e46b52..f4f614daebed 100644
--- a/net-libs/gnutls/gnutls-3.5.15.ebuild
+++ b/net-libs/gnutls/gnutls-3.5.15.ebuild
@@ -89,9 +89,16 @@ multilib_src_configure() {
local libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
# TPM needs to be tested before being enabled
+ libconf+=( --without-tpm )
+
# hardware-accell is disabled on OSX because the asm files force
# GNU-stack (as doesn't support that) and when that's removed ld
# complains about duplicate symbols
+ [[ ${CHOST} == *-darwin* ]] && libconf+=( --disable-hardware-acceleration )
+
+ # Cygwin as does not understand these asm files at all
+ [[ ${CHOST} == *-cygwin* ]] && libconf+=( --disable-hardware-acceleration )
+
ECONF_SOURCE=${S} econf \
$(multilib_native_enable manpages) \
$(multilib_native_use_enable doc gtk-doc) \
@@ -117,9 +124,7 @@ multilib_src_configure() {
$(use_with zlib) \
--with-unbound-root-key-file="${EPREFIX}/etc/dnssec/root-anchors.txt" \
--without-included-libtasn1 \
- --without-tpm \
- "${libconf[@]}" \
- $([[ ${CHOST} == *-darwin* ]] && echo --disable-hardware-acceleration)
+ "${libconf[@]}"
}
multilib_src_install_all() {