summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libpcap/libpcap-9999.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index 5a09a1502eb8..1c311cddf268 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit autotools eutils git-r3 multilib-minimal
DESCRIPTION="A system-independent library for user-level network packet capture"
@@ -12,7 +12,7 @@ EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="bluetooth dbus ipv6 netlink static-libs canusb"
+IUSE="bluetooth dbus netlink static-libs canusb"
RDEPEND="
bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
@@ -26,16 +26,20 @@ DEPEND="${RDEPEND}
dbus? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
+ "${FILESDIR}"/${PN}-1.6.1-configure.patch
+ "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
+ "${FILESDIR}"/${PN}-1.7.2-libnl.patch
+ )
src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch \
- "${FILESDIR}"/${PN}-1.6.1-configure.patch \
- "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch \
- "${FILESDIR}"/${PN}-1.7.2-libnl.patch
+ default
mkdir bluetooth || die
cp "${FILESDIR}"/mgmt.h bluetooth/ || die
+ eapply_user
+
eautoreconf
}
@@ -43,7 +47,6 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \
$(use_enable bluetooth) \
- $(use_enable ipv6) \
$(use_enable canusb) \
$(use_enable dbus) \
$(use_with netlink libnl)