summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/librsync/librsync-0.9.7-r3.ebuild')
-rw-r--r--net-libs/librsync/librsync-0.9.7-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/librsync/librsync-0.9.7-r3.ebuild b/net-libs/librsync/librsync-0.9.7-r3.ebuild
new file mode 100644
index 000000000000..cb7a0da16ce7
--- /dev/null
+++ b/net-libs/librsync/librsync-0.9.7-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Flexible remote checksum-based differencing"
+HOMEPAGE="https://librsync.github.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-huge-files.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-getopt.patch
+ "${FILESDIR}"/${P}-implicit-declaration.patch
+ "${FILESDIR}"/${P}-fix-testsuite.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' \
+ -i configure.ac || die
+
+ autotools-utils_src_prepare
+}