summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtelnet/libtelnet-0.23.ebuild')
-rw-r--r--net-libs/libtelnet/libtelnet-0.23.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/libtelnet/libtelnet-0.23.ebuild b/net-libs/libtelnet/libtelnet-0.23.ebuild
new file mode 100644
index 000000000000..f497242059f6
--- /dev/null
+++ b/net-libs/libtelnet/libtelnet-0.23.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Simple RFC-complient TELNET implementation as a C library"
+HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
+SRC_URI="https://github.com/seanmiddleditch/libtelnet/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -type f -name '*.a' -delete || die
+}