summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp3/nghttp3-0_pre20190912.ebuild')
-rw-r--r--net-libs/nghttp3/nghttp3-0_pre20190912.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
index 82c8375e72b0..03aecea14f7e 100644
--- a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
+++ b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == 9999 ]] ; then
@@ -33,9 +34,9 @@ multilib_src_configure() {
-DENABLE_EXAMPLES=OFF
-DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
- cmake-utils_src_make check
+ cmake_build check
}