summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/zmqpp/zmqpp-4.1.2.ebuild')
-rw-r--r--net-libs/zmqpp/zmqpp-4.1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/zmqpp/zmqpp-4.1.2.ebuild b/net-libs/zmqpp/zmqpp-4.1.2.ebuild
new file mode 100644
index 000000000000..705fcda3533d
--- /dev/null
+++ b/net-libs/zmqpp/zmqpp-4.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="ZeroMQ 'highlevel' C++ bindings"
+HOMEPAGE="https://github.com/zeromq/zmqpp"
+if [[ $PV == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zeromq/zmqpp.git"
+else
+ SRC_URI="https://github.com/zeromq/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND="net-libs/zeromq[static-libs?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DIS_TRAVIS_CI_BUILD=OFF
+ -DZMQPP_BUILD_SHARED=ON
+ $(cmake-utils_use static-libs ZMQPP_BUILD_STATIC)
+ )
+
+ cmake-utils_src_configure
+}