summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libident/libident-0.32-r1.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/net-libs/libident/libident-0.32-r1.ebuild b/net-libs/libident/libident-0.32-r1.ebuild
index 99d4cc5919bf..6f49ea50ba4d 100644
--- a/net-libs/libident/libident-0.32-r1.ebuild
+++ b/net-libs/libident/libident-0.32-r1.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit autotools
DESCRIPTION="A small library to interface to the Ident protocol server"
HOMEPAGE="http://www.simphalempin.com/dev/libident/"
@@ -10,12 +12,17 @@ SRC_URI="http://people.via.ecp.fr/~rem/libident/${P}.tar.bz2"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sparc x86"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS README
+ default
+ find "${ED}" -name '*.la' -delete || die
}