summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/tpop3d')
-rw-r--r--net-mail/tpop3d/Manifest1
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch20
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.4.init30
-rw-r--r--net-mail/tpop3d/metadata.xml13
-rw-r--r--net-mail/tpop3d/tpop3d-1.5.5.ebuild97
5 files changed, 161 insertions, 0 deletions
diff --git a/net-mail/tpop3d/Manifest b/net-mail/tpop3d/Manifest
new file mode 100644
index 000000000000..c77160ade434
--- /dev/null
+++ b/net-mail/tpop3d/Manifest
@@ -0,0 +1 @@
+DIST tpop3d-1.5.5.tar.gz 285027 SHA256 85aca837339b41f4c01c33dadd195cad7dd5942477e773845cbabc4af30cf258
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch b/net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch
new file mode 100644
index 000000000000..149dc9430dd0
--- /dev/null
+++ b/net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch
@@ -0,0 +1,20 @@
+commit 8ed9a7721a406fea7dfc7f0a5eb6e68f3d63a99e
+Author: Eray Aslan <eras@gentoo.org>
+Date: Fri Jun 3 13:52:55 2011 +0000
+
+ Fix linking against gold
+
+diff --git a/configure.in b/configure.in
+index ac16864..a260652 100644
+--- a/configure.in
++++ b/configure.in
+@@ -587,7 +587,8 @@ fi
+ # OpenSSL
+ if test x"$enable_tls" = x"yes" || test x"$enable_sha1_passwords" = x"yes"
+ then
+- AC_CHECK_LIB2(ssl, SSL_new, [], AC_MSG_ERROR([[TLS/SHA1 passwords enabled, but can't find libssl]]), -lcrypto)
++ AC_CHECK_LIB(ssl, SSL_new, [], AC_MSG_ERROR([[TLS/SHA1 passwords enabled, but can't find libssl]]))
++ AC_CHECK_LIB(crypto, SHA1_Init, [], AC_MSG_ERROR([[TLS/SHA1 passwords enabled, but can't find libcrypto]]))
+ fi
+
+ # GNU dbm
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.4.init b/net-mail/tpop3d/files/tpop3d-1.5.4.init
new file mode 100644
index 000000000000..1d60bc67ebc2
--- /dev/null
+++ b/net-mail/tpop3d/files/tpop3d-1.5.4.init
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2
+# $Id$
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/tpop3d/tpop3d.conf ] ; then
+ eerror "You need an /etc/tpop3d/tpop3d.conf file to run tpop3d"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting tpop3d"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/sbin/tpop3d -- -f /etc/tpop3d/tpop3d.conf \
+ -p /var/run/tpop3d.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tpop3d"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/tpop3d
+ eend $?
+}
diff --git a/net-mail/tpop3d/metadata.xml b/net-mail/tpop3d/metadata.xml
new file mode 100644
index 000000000000..7a0796dda823
--- /dev/null
+++ b/net-mail/tpop3d/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <use>
+ <flag name="authexternal">Enable authentication by an external program</flag>
+ <flag name="drac">Enable dynamic relay support in the tpop3d pop3 server</flag>
+ <flag name="flatfile">Enable authentication against /etc/passwd-style flat files</flag>
+ <flag name="passwd">Enable /etc/passwd authentication</flag>
+ <flag name="sha1">Use OpenSSL for sha1 encrypted passwords.</flag>
+ <flag name="shadow">Enable /etc/shadow authentication</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-mail/tpop3d/tpop3d-1.5.5.ebuild b/net-mail/tpop3d/tpop3d-1.5.5.ebuild
new file mode 100644
index 000000000000..7bb1ef69fc30
--- /dev/null
+++ b/net-mail/tpop3d/tpop3d-1.5.5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="An extensible POP3 server with vmail-sql/MySQL support"
+HOMEPAGE="http://savannah.nongnu.org/projects/tpop3d/"
+SRC_URI="http://download.savannah.nongnu.org/releases/tpop3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="authexternal debug drac flatfile gdbm ldap maildir mbox mysql offensive
+ pam passwd perl postgres +sha1 shadow ssl tcpd"
+
+RDEPEND="sha1? ( >=dev-libs/openssl-0.9.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql[server] )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ pam? ( virtual/pam
+ >=net-mail/mailbase-0.00-r8 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ drac? ( mail-client/drac )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.5.4-gold.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+ local noauth=0
+
+ # Various authentication methods
+ use authexternal && myconf="${myconf} --enable-auth-other"
+ use flatfile && myconf="${myconf} --enable-auth-flatfile"
+ use gdbm && myconf="${myconf} --enable-auth-gdbm"
+ use ldap && myconf="${myconf} --enable-auth-ldap"
+ use mysql && myconf="${myconf} --enable-auth-mysql"
+ use pam || myconf="${myconf} --disable-auth-pam"
+ use passwd && myconf="${myconf} --enable-auth-passwd"
+ use perl && myconf="${myconf} --enable-auth-perl"
+ use postgres && myconf="${myconf} --enable-auth-pgsql"
+ use shadow && myconf="${myconf} --enable-auth-passwd --enable-shadow-passwords"
+
+ use authexternal || use flatfile || use gdbm || use ldap || use mysql ||
+ use pam || use passwd || use perl || use postgres || use shadow ||
+ noauth=1
+
+ if [[ ${noauth} -eq 1 ]]; then
+ ewarn "None of tpop3d's authentication mechanism USE flags are set."
+ ewarn "As a result tpop3d will be built with /etc/passwd authentication only."
+ myconf="${myconf} --enable-auth-passwd"
+ fi
+
+ # Other optional features
+ use debug && myconf="${myconf} --enable-backtrace"
+ use maildir && myconf="${myconf} --enable-mbox-maildir"
+ use mbox || myconf="${myconf} --disable-mbox-bsd"
+ use offensive || myconf="${myconf} --disable-snide-comments"
+ use sha1 || myconf="${myconf} --disable-sha1-passwords"
+ use ssl && myconf="${myconf} --enable-tls"
+ use tcpd && myconf="${myconf} --enable-tcp-wrappers"
+
+ # Install mail-client/drac for integration with tpop3d
+ use drac && myconf="${myconf} --enable-drac"
+
+ econf ${myconf}
+
+ # Causes crash with "stack smashing attack" on connect, because of bug in
+ # SSP (bug #115285)
+ filter-flags -fstack-protector
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tpop3d
+
+ if use pam ; then
+ dodir /etc/pam.d
+ dosym /etc/pam.d/pop3 /etc/pam.d/tpop3d
+ fi
+
+ newinitd "${FILESDIR}/${PN}-1.5.4.init" tpop3d
+}
+
+pkg_postinst() {
+ elog "Read the tpop3d.conf manpage"
+ elog "Please create /etc/tpop3d/tpop3d.conf to fit your configuration"
+}