summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/iperf/iperf-3.1.5.ebuild')
-rw-r--r--net-misc/iperf/iperf-3.1.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/iperf/iperf-3.1.5.ebuild b/net-misc/iperf/iperf-3.1.5.ebuild
new file mode 100644
index 000000000000..5d904a45bcdb
--- /dev/null
+++ b/net-misc/iperf/iperf-3.1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+HOMEPAGE="https://github.com/esnet/iperf/"
+SRC_URI="https://codeload.github.com/esnet/${PN}/tar.gz/${PV/_beta/b} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="sctp static-libs"
+
+DEPEND="sctp? ( net-misc/lksctp-tools )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_beta/b}
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.5-flags.patch )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}"/iperf.confd iperf3
+ newinitd "${FILESDIR}"/iperf3.initd iperf3
+ prune_libtool_files
+}