summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ipsc/ipsc-0.4.3.2-r2.ebuild')
-rw-r--r--net-misc/ipsc/ipsc-0.4.3.2-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/ipsc/ipsc-0.4.3.2-r2.ebuild b/net-misc/ipsc/ipsc-0.4.3.2-r2.ebuild
new file mode 100644
index 000000000000..79406ed0a696
--- /dev/null
+++ b/net-misc/ipsc/ipsc-0.4.3.2-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="IP Subnet Calculator"
+HOMEPAGE="http://packages.debian.org/unstable/net/ipsc"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:^CC = gcc:CC = $(tc-getCC):" \
+ -e "/^CFLAGS = .*/d" \
+ -e "s/^LIBS = /LDLIBS = /" \
+ -e '/$(CC).*\\$/,+1d' \
+ -e '/$(CC)/d' \
+ src/Makefile || die "Unable to sed upstream Makefile"
+}
+
+src_compile() {
+ cd src
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ dodoc README ChangeLog TODO CONTRIBUTORS
+ dobin src/ipsc
+ doman src/ipsc.1
+}