summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild')
-rw-r--r--net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild b/net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild
new file mode 100644
index 000000000000..a552889ed750
--- /dev/null
+++ b/net-misc/netkit-bootpd/netkit-bootpd-2.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils toolchain-funcs
+
+MY_P=${P/netkit-}
+
+DESCRIPTION="Netkit - bootp"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netboot/"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netboot/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ppc ~sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake linux || die
+}
+
+src_install() {
+ dosbin bootp{d,ef,gw,test} || die
+
+ for x in d ef gw test; do
+ dosym bootp${x} /usr/sbin/in.bootp${x} || die
+ done
+
+ doman *.5 *.8
+ dodoc Announce Changes Problems README{,-linux} ToDo
+}