summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ofono/ofono-1.17.ebuild')
-rw-r--r--net-misc/ofono/ofono-1.17.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/net-misc/ofono/ofono-1.17.ebuild b/net-misc/ofono/ofono-1.17.ebuild
deleted file mode 100644
index a44a2b1ae43e..000000000000
--- a/net-misc/ofono/ofono-1.17.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib systemd
-
-DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
-HOMEPAGE="http://ofono.org/"
-SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem threads tools +udev"
-
-REQUIRED_USE="dundee? ( bluetooth )"
-
-RDEPEND=">=sys-apps/dbus-1.4
- >=dev-libs/glib-2.28
- net-misc/mobile-broadband-provider-info
- bluetooth? ( >=net-wireless/bluez-4.99 )
- udev? ( virtual/udev )
- examples? ( dev-python/dbus-python )
- tools? ( virtual/libusb:1 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( ChangeLog AUTHORS )
-
-src_configure() {
- econf \
- $(use_enable threads) \
- $(use_enable udev) \
- $(use_enable isimodem) \
- $(use_enable atmodem) \
- $(use_enable cdmamodem) \
- $(use_enable datafiles) \
- $(use_enable dundee) \
- $(use_enable bluetooth) \
- $(use_enable phonesim) \
- $(use_enable provision) \
- $(use_enable qmimodem) \
- $(use_enable tools) \
- $(use_enable examples test) \
- --disable-maintainer-mode \
- --localstatedir=/var \
- --with-systemdunitdir="$(systemd_get_unitdir)"
-}
-
-src_install() {
- default
-
- if use tools ; then
- dobin tools/auto-enable \
- tools/huawei-audio \
- tools/lookup-provider-name \
- tools/lookup-apn \
- tools/get-location \
- tools/qmi \
- tools/tty-redirector
- fi
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- use doc && dodoc doc/*.txt
-}