summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/portspoof/portspoof-1.1.ebuild')
-rw-r--r--net-misc/portspoof/portspoof-1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/portspoof/portspoof-1.1.ebuild b/net-misc/portspoof/portspoof-1.1.ebuild
new file mode 100644
index 000000000000..cedb2e10fc20
--- /dev/null
+++ b/net-misc/portspoof/portspoof-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="return SYN+ACK for every port connection attempt"
+HOMEPAGE="http://portspoof.org/"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://github.com/drk1wi/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/drk1wi/portspoof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}