summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rclone/rclone-1.42.ebuild')
-rw-r--r--net-misc/rclone/rclone-1.42.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/net-misc/rclone/rclone-1.42.ebuild b/net-misc/rclone/rclone-1.42.ebuild
deleted file mode 100644
index 2c530609ee7b..000000000000
--- a/net-misc/rclone/rclone-1.42.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build bash-completion-r1
-EGO_PN="github.com/ncw/${PN}"
-
-if [[ ${PV} == *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64 ~arm ~x86"
- EGIT_COMMIT="v${PV}"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A program to sync files to and from various cloud storage providers"
-HOMEPAGE="https://rclone.org/"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_install() {
- dobin ${PN}
- doman src/${EGO_PN}/${PN}.1
- dodoc src/${EGO_PN}/README.md
-
- ./rclone genautocomplete bash ${PN}.bash || die
- newbashcomp ${PN}.bash ${PN}
-
- ./rclone genautocomplete zsh ${PN}.zsh || die
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-}