summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rsync/rsync-3.2.2.ebuild')
-rw-r--r--net-misc/rsync/rsync-3.2.2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-misc/rsync/rsync-3.2.2.ebuild b/net-misc/rsync/rsync-3.2.2.ebuild
index c02794fd0b9b..fb78f513976f 100644
--- a/net-misc/rsync/rsync-3.2.2.ebuild
+++ b/net-misc/rsync/rsync-3.2.2.ebuild
@@ -81,8 +81,9 @@ src_configure() {
$(use_enable zstd)
)
- if [[ "${ARCH}" == "amd64" ]] ; then
- # SIMD is only available for x86_64 right now (#728868)
+ if use elibc_glibc && [[ "${ARCH}" == "amd64" ]] ; then
+ # SIMD is only available for x86_64 right now
+ # and only on glibc (#728868)
myeconfargs+=( $(use_enable cpu_flags_x86_sse2 simd) )
else
myeconfargs+=( --disable-simd )