summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sgopherd/sgopherd-17.09.ebuild')
-rw-r--r--net-misc/sgopherd/sgopherd-17.09.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/sgopherd/sgopherd-17.09.ebuild b/net-misc/sgopherd/sgopherd-17.09.ebuild
new file mode 100644
index 000000000000..742b26b78b00
--- /dev/null
+++ b/net-misc/sgopherd/sgopherd-17.09.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Small Gopher Server written in GNU Bash"
+HOMEPAGE="https://github.com/vain/sgopherd"
+SRC_URI="https://github.com/vain/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="app-shells/bash
+ sys-apps/sed
+ sys-apps/xinetd"
+
+src_prepare() {
+ # Set default user to run sgopherd
+ sed -i -e '/user/s/http/nobody/' xinetd/xinetd-example.conf || die 'sed failed'
+
+ eapply_user
+}
+
+src_install() {
+ dodoc README
+ doman man8/"${PN}".8
+ dobin "${PN}"
+ insinto /etc/xinetd.d
+ newins xinetd/xinetd-example.conf "${PN}"
+ # TODO: add installation of systemd-related files
+}
+
+pkg_postinst() {
+ elog "${PN} can be launched through xinetd"
+ elog "Configuration options are in /etc/xinetd.d/${PN}"
+}