summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/shmux/shmux-1.0.ebuild')
-rw-r--r--net-misc/shmux/shmux-1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/shmux/shmux-1.0.ebuild b/net-misc/shmux/shmux-1.0.ebuild
new file mode 100644
index 000000000000..6e68100e59a8
--- /dev/null
+++ b/net-misc/shmux/shmux-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Program for executing the same command on many hosts in parallel"
+HOMEPAGE="http://web.taranis.org/shmux/"
+SRC_URI="http://web.taranis.org/${PN}/dist/${P}.tgz"
+
+LICENSE="shmux"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="pcre"
+RESTRICT="test"
+
+RDEPEND="
+ pcre? ( dev-libs/libpcre )
+ sys-libs/ncurses
+"
+DEPEND="${RDEPEND}
+ virtual/awk"
+
+src_compile() {
+ econf $(use_with pcre) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin src/shmux || die "dobin failed"
+ doman shmux.1 || die "doman failed"
+ dodoc CHANGES || die "dodoc failed"
+}