summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sslh/files/sslh-1.18-systemd-generator.patch')
-rw-r--r--net-misc/sslh/files/sslh-1.18-systemd-generator.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-misc/sslh/files/sslh-1.18-systemd-generator.patch b/net-misc/sslh/files/sslh-1.18-systemd-generator.patch
new file mode 100644
index 000000000000..476de2a4c1e1
--- /dev/null
+++ b/net-misc/sslh/files/sslh-1.18-systemd-generator.patch
@@ -0,0 +1,26 @@
+https://patch-diff.githubusercontent.com/raw/yrutschle/sslh/pull/98
+--- a/Makefile
++++ b/Makefile
+@@ -27,6 +27,8 @@ CFLAGS ?=-Wall -g $(CFLAGS_COV)
+ LIBS=
+ OBJS=common.o sslh-main.o probe.o tls.o
+
++CONDITIONAL_TARGETS=
++
+ ifneq ($(strip $(USELIBWRAP)),)
+ LIBS:=$(LIBS) -lwrap
+ CPPFLAGS+=-DLIBWRAP
+@@ -54,10 +56,11 @@ endif
+ ifneq ($(strip $(USESYSTEMD)),)
+ LIBS:=$(LIBS) -lsystemd
+ CPPFLAGS+=-DSYSTEMD
++ CONDITIONAL_TARGETS+=systemd-sslh-generator
+ endif
+
+
+-all: sslh $(MAN) echosrv
++all: sslh $(MAN) echosrv $(CONDITIONAL_TARGETS)
+
+ .c.o: *.h
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $<
+