summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/tlsdate/tlsdate-0.0.13.ebuild')
-rw-r--r--net-misc/tlsdate/tlsdate-0.0.13.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-misc/tlsdate/tlsdate-0.0.13.ebuild b/net-misc/tlsdate/tlsdate-0.0.13.ebuild
index 5b1f523bbfd3..dab1fa89695c 100644
--- a/net-misc/tlsdate/tlsdate-0.0.13.ebuild
+++ b/net-misc/tlsdate/tlsdate-0.0.13.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit autotools eutils systemd vcs-snapshot user
@@ -15,18 +15,23 @@ SLOT="0"
KEYWORDS="amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ~s390 ~sh ~sparc x86"
IUSE="dbus +seccomp static-libs"
-DEPEND="dev-libs/openssl
- dev-libs/libevent
+DEPEND="dev-libs/openssl:0=
+ dev-libs/libevent:=
dbus? ( sys-apps/dbus )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-tlsdated-service.patch
+)
+
src_prepare() {
# Use the system cert store rather than a custom one specific
# to the tlsdate package. #534394
sed -i \
-e 's:/tlsdate/ca-roots/tlsdate-ca-roots.conf:/ssl/certs/ca-certificates.crt:' \
Makefile.am || die
- epatch "${FILESDIR}"/${P}-tlsdated-service.patch
+
+ default
eautoreconf
}