summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/vpncwatch/vpncwatch-1.8.ebuild')
-rw-r--r--net-misc/vpncwatch/vpncwatch-1.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/vpncwatch/vpncwatch-1.8.ebuild b/net-misc/vpncwatch/vpncwatch-1.8.ebuild
new file mode 100644
index 000000000000..47b432c72c29
--- /dev/null
+++ b/net-misc/vpncwatch/vpncwatch-1.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A keepalive daemon for vpnc on Linux systems"
+HOMEPAGE="http://github.com/dcantrell/vpncwatch/"
+SRC_URI="http://github.com/downloads/dcantrell/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/vpnc"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-Makefile.patch"
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README ChangeLog AUTHORS
+}