summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wput/wput-0.6.1-r1.ebuild')
-rw-r--r--net-misc/wput/wput-0.6.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/wput/wput-0.6.1-r1.ebuild b/net-misc/wput/wput-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..354b883b95e3
--- /dev/null
+++ b/net-misc/wput/wput-0.6.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tiny program like wget, to upload files/whole directories via FTP"
+HOMEPAGE="http://wput.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug nls ssl"
+
+RDEPEND="ssl? ( net-libs/gnutls )"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6-gentoo.diff"
+ "${FILESDIR}/${PN}-0.6-respectldflags.patch"
+)
+
+DOCS=( ChangeLog INSTALL TODO )
+
+src_configure() {
+ local myconf="--enable-g-switch=no"
+ use debug && myconf="--enable-memdbg=yes"
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ "${myconf}"
+}
+
+src_install() {
+ default
+}