summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/youtube-dl/youtube-dl-2019.04.17.ebuild')
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.04.17.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/youtube-dl-2019.04.17.ebuild b/net-misc/youtube-dl/youtube-dl-2019.04.17.ebuild
new file mode 100644
index 000000000000..8249fc9c0e19
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.04.17.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6,3_7})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}