summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/connman-notify/Manifest2
-rw-r--r--net-misc/connman-notify/connman-notify-0_pre20140623.ebuild38
-rw-r--r--net-misc/connman-notify/connman-notify-0_pre20191003.ebuild (renamed from net-misc/connman-notify/connman-notify-0_pre20140623-r1.ebuild)4
-rw-r--r--net-misc/connman-notify/files/connman-notify-py3-support.patch38
4 files changed, 2 insertions, 80 deletions
diff --git a/net-misc/connman-notify/Manifest b/net-misc/connman-notify/Manifest
index bdd935254e98..17f0cb40722a 100644
--- a/net-misc/connman-notify/Manifest
+++ b/net-misc/connman-notify/Manifest
@@ -1 +1 @@
-DIST connman-notify-0_pre20140623.tar.bz2 2858 BLAKE2B b76865e5392f9b6ed2dada5b323e0f867fa70b5ba21bb6342069f7f6a28468d2915dc9c573bcb4ebc061c3039fa6f0bbfd6969464d264b710f3aee149b1162a5 SHA512 8da432cfe0653c29d83afffeacd11e9d66795be061040286ec8b90ce28c334c729af24cb7e1aee0f32e2b2626949f7ee9c95c52b4a3191392236bad7b204a267
+DIST connman-notify-0_pre20191003.tar.bz2 9102 BLAKE2B 7c31de51b21f7cae475b543cf74bba1d969c779f00d1dab7ebce2da6758e1dec6c3c06ae1f0ab133292fc03c1dc61cd1c18c4719311f7a7b65f1771afb097b64 SHA512 6ca8dce104fc5c94af8ef4fab94e44f6a921017d58bbe12660f6bb6a6a0ab6b0808bb7584b75d2acaa486d4cbe718f436fcf7924d6baac97b59a2b77a13215f4
diff --git a/net-misc/connman-notify/connman-notify-0_pre20140623.ebuild b/net-misc/connman-notify/connman-notify-0_pre20140623.ebuild
deleted file mode 100644
index 3d32d97d793b..000000000000
--- a/net-misc/connman-notify/connman-notify-0_pre20140623.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit desktop python-single-r1 vcs-snapshot
-
-MY_COMMIT="0ed9b5e4a0e1f03c83c4589cabf410cac66cd11d"
-
-DESCRIPTION="Desktop notification integration for connman"
-HOMEPAGE="https://gitlab.com/wavexx/connman-notify/"
-SRC_URI="https://gitlab.com/wavexx/connman-notify/repository/${MY_COMMIT}/archive.tar.bz2 -> ${P}.tar.bz2"
-
-EGIT_REPO_URI="https://gitlab.com/wavexx/connman-notify.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- dev-python/notify-python[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- net-misc/connman
- virtual/notification-daemon"
-
-src_install() {
- python_fix_shebang ${PN}
- dobin ${PN}
- dodoc README.rst
-
- make_desktop_entry ${PN} ${PN} ${PN} Network
-}
diff --git a/net-misc/connman-notify/connman-notify-0_pre20140623-r1.ebuild b/net-misc/connman-notify/connman-notify-0_pre20191003.ebuild
index f3fa6cd20fef..4c4c3e6b29ed 100644
--- a/net-misc/connman-notify/connman-notify-0_pre20140623-r1.ebuild
+++ b/net-misc/connman-notify/connman-notify-0_pre20191003.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit desktop python-single-r1 vcs-snapshot
-MY_COMMIT="0ed9b5e4a0e1f03c83c4589cabf410cac66cd11d"
+MY_COMMIT="4f1e0a6b27ebf5d9b7508594188fe0f86c34ec52"
DESCRIPTION="Desktop notification integration for connman"
HOMEPAGE="https://gitlab.com/wavexx/connman-notify/"
@@ -27,8 +27,6 @@ RDEPEND="${PYTHON_DEPS}
net-misc/connman
virtual/notification-daemon"
-PATCHES=( "${FILESDIR}"/connman-notify-py3-support.patch )
-
src_install() {
python_fix_shebang ${PN}
dobin ${PN}
diff --git a/net-misc/connman-notify/files/connman-notify-py3-support.patch b/net-misc/connman-notify/files/connman-notify-py3-support.patch
deleted file mode 100644
index 59c888495560..000000000000
--- a/net-misc/connman-notify/files/connman-notify-py3-support.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/connman-notify
-+++ b/connman-notify
-@@ -7,8 +7,8 @@
- import argparse
- import dbus
- import dbus.mainloop.glib
--import glib
--import pynotify
-+from gi.repository import GLib
-+from gi.repository import Notify
-
- APP_NAME = 'connman'
- SHORT_DEV = True
-@@ -22,7 +22,7 @@
-
-
- def notify(subject, body):
-- ntf = pynotify.Notification(subject, body)
-+ ntf = Notify.Notification.new(subject, body)
- ntf.show()
-
-
-@@ -79,7 +79,7 @@
- if args.hide_addr: SHOW_ADDR = False
-
- dbus.mainloop.glib.DBusGMainLoop(set_as_default=True)
-- pynotify.init(APP_NAME)
-+ Notify.init(APP_NAME)
- bus = dbus.SystemBus()
- manager = dbus.Interface(bus.get_object("net.connman", "/"), "net.connman.Manager")
-
-@@ -88,5 +88,5 @@
- signal_name="PropertyChanged",
- path_keyword="path")
-
-- mainloop = glib.MainLoop()
-+ mainloop = GLib.MainLoop()
- mainloop.run()