summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2018.12.09.ebuild117
2 files changed, 0 insertions, 118 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index ef8296bd615e..7c33773ea3ba 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1 @@
-DIST youtube-dl-2018.12.09.tar.gz 3073427 BLAKE2B 2b97f062d2e32af71c491ab518d9d86b8fdc6c93f96052ec931b72752e8d5dc5064a24719bcbbd700dbae5b18f5ada7a447245ecc88c952f357d0a90c702bd9c SHA512 00e233cfe21cbaa871e8ef4478c052a06129d24d8fd509de2aaf826a44eb9fabd370d931e8cc58af2406d4ce07bb2296a8bf675e818e55dde3d92c72073a3596
DIST youtube-dl-2018.12.17.tar.gz 3074432 BLAKE2B b6f4b3a7a2c2159093494230219914ee4a2f87194ebe741cc4687aefa76dfef09c282bcc6534030bb65cd87a641b05cc74bd74eecc0c78b57157970fbea98121 SHA512 88d98391d110d6542503590c4735c765137cde43bc3a1f1b33b197d323a1226ed550d559f67bd4aadab3c82de8a471fa71bf4e1440e5641e1c51ba5cb7059904
diff --git a/net-misc/youtube-dl/youtube-dl-2018.12.09.ebuild b/net-misc/youtube-dl/youtube-dl-2018.12.09.ebuild
deleted file mode 100644
index 7bce052e27ce..000000000000
--- a/net-misc/youtube-dl/youtube-dl-2018.12.09.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://rg3.github.com/youtube-dl/"
-SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="+offensive test"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-python_prepare_all() {
- if ! use offensive; then
- sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
- youtube_dl/version.py || die
- # these have single line import statements
- local xxx=(
- alphaporno anysex behindkink camwithher chaturbate eporner
- eroprofile extremetube foxgay goshgay hellporno hentaistigma
- hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
- pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
- slutload spankbang spankwire sunporno thisav vporn watchindianporn
- xbef xnxx xtube xvideos xxxymovies youjizz youporn
- )
- # these have multi-line import statements
- local mxxx=(
- drtuber fourtube motherless pornhub redtube tnaflix tube8 xhamster
- )
- # do single line imports
- sed -i \
- -e $( printf '/%s/d;' ${xxx[@]} ) \
- youtube_dl/extractor/extractors.py \
- || die
-
- # do multiple line imports
- sed -i \
- -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
- youtube_dl/extractor/extractors.py \
- || die
-
- sed -i \
- -e $( printf '/%s/d;' ${mxxx[@]} ) \
- youtube_dl/extractor/generic.py \
- || die
-
- rm \
- $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
- $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
- test/test_age_restriction.py \
- || die
- fi
-
- eapply_user
-
- distutils-r1_python_prepare_all
-}
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-python_test() {
- emake test
-}
-
-python_install_all() {
- dodoc README.txt
- doman ${PN}.1
-
- newbashcomp ${PN}.bash-completion ${PN}
-
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-
- insinto /usr/share/fish/vendor_completions.d
- doins ${PN}.fish
-
- distutils-r1_python_install_all
-
- rm -r "${ED}"/usr/etc || die
- rm -r "${ED}"/usr/share/doc/youtube_dl || die
-}
-
-pkg_postinst() {
- elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
- elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
- elog
- elog "${PN} works fine on its own on most sites. However, if you want"
- elog "to convert video/audio, you'll need avconf (media-video/libav) or"
- elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
- elog "videos can be retrieved in a higher quality format without sound."
- elog "${PN} will detect whether avconv/ffmpeg is present and"
- elog "automatically pick the best option."
- elog
- elog "Videos or video formats streamed via RTMP protocol can only be"
- elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
- elog "Downloading MMS and RTSP videos requires either mplayer"
- elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
- elog
- elog "If you want ${PN} to embed thumbnails from the metadata into the"
- elog "resulting MP4 files, consider installing media-video/atomicparsley"
-}