summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2018.01.07.ebuild115
2 files changed, 0 insertions, 116 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 573f0c199b0a..d374f4966b86 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,5 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 BLAKE2B 2aff8710a296140a4329b0f8e7f57526684ca114ba39a7397eef81b1b79b4b5dfae685c1f0011cddf8569d8df1e50111bbce7f12647c067972c79ea3b116b2ff SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c
DIST youtube-dl-2017.11.15.tar.gz 2834012 BLAKE2B fd93e3923f99874be58681a886c09e31ac10063975ab636badf27e59b44743c72cddf05e3a431c49ffd0f7b40f9b005f4d90feff85d4ca889dee80833300b076 SHA512 e10c0d53db7fdfb02610b53f54046c0a9354b305ba05c5d00a43649a283a6449263f66ff56171d52cf18f906c6aeccc25dc48ea708b4b1bb2b8323b937abca96
-DIST youtube-dl-2018.01.07.tar.gz 2877870 BLAKE2B 8def952710c4500e251641b4ca458ba4810c84435c504ca44569211d3d762efe4a5086f12bf9edee0944b5894697e5be359abead41282f637bab83addbbf67cc SHA512 ac5f603eb61b367fb26c07213f8350b1a305bad41a4d6beaa65f1568e6365e666818c67be35ce118de495bbdc980c9eb599b9273e7bb79f2e40dd23732d9a6fd
DIST youtube-dl-2018.01.14.tar.gz 2885608 BLAKE2B 57e4eac94ab3ff615470115d2d25de20633828f95d041e17659ae890564f8de5bc67ad1f6209551e3fd7a654892d9ce9eb3e87f016036b10211498b6c526e43b SHA512 687a38a96e8b09452c9460cd4d3796d7334bbe9ff2563adc700865ed8f30f5dd7254aaf3b57a7bdaacda4147210f9390e5c0f739449992abc680a037013189e2
DIST youtube-dl-2018.01.18.tar.gz 2885167 BLAKE2B 2615c70fbc119c0d07cc797e9c36ea9a751a6603da91ff6822440cec0ccf924ac9cf76b08cb2d2975fa6572473d41cd898f71ceb43529aa27def1a15b7e86367 SHA512 8770b82b61b9038eccdbfe1391d85b7ac8edd8ff1258259a8955ca12b98559b889b0d98e8d39df1f27e7c7dd92cd7ee303af15de19eedfa74206d2a66155c12b
diff --git a/net-misc/youtube-dl/youtube-dl-2018.01.07.ebuild b/net-misc/youtube-dl/youtube-dl-2018.01.07.ebuild
deleted file mode 100644
index db51a779b025..000000000000
--- a/net-misc/youtube-dl/youtube-dl-2018.01.07.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://rg3.github.com/youtube-dl/"
-SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="+offensive test"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-python_prepare_all() {
- if ! use offensive; then
- sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
- youtube_dl/version.py || die
- # these have single line import statements
- local xxx=(
- alphaporno anysex behindkink camwithher chaturbate eporner
- eroprofile extremetube foxgay goshgay hellporno hentaistigma
- hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
- pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
- slutload spankbang spankwire sunporno thisav tube8 vporn
- watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz youporn
- )
- # these have multi-line import statements
- local mxxx=(
- drtuber fourtube motherless pornhub redtube tnaflix xhamster
- )
- # do single line imports
- sed -i \
- -e $( printf '/%s/d;' ${xxx[@]} ) \
- youtube_dl/extractor/extractors.py \
- || die
-
- # do multiple line imports
- sed -i \
- -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
- youtube_dl/extractor/extractors.py \
- || die
-
- sed -i \
- -e $( printf '/%s/d;' ${mxxx[@]} ) \
- youtube_dl/extractor/generic.py \
- || die
-
- rm \
- $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
- $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
- test/test_age_restriction.py \
- || die
- fi
-
- eapply_user
-
- distutils-r1_python_prepare_all
-}
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-python_test() {
- emake test
-}
-
-python_install_all() {
- dodoc README.txt
- doman ${PN}.1
-
- newbashcomp ${PN}.bash-completion ${PN}
-
- insinto /usr/share/zsh/site-functions
- newins youtube-dl.zsh _youtube-dl
-
- insinto /usr/share/fish/completions
- doins youtube-dl.fish
-
- distutils-r1_python_install_all
-
- rm -r "${ED}"/usr/etc || die
- rm -r "${ED}"/usr/share/doc/youtube_dl || die
-}
-
-pkg_postinst() {
- elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
- elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
- elog
- elog "${PN} works fine on its own on most sites. However, if you want"
- elog "to convert video/audio, you'll need avconf (media-video/libav) or"
- elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
- elog "videos can be retrieved in a higher quality format without sound."
- elog "${PN} will detect whether avconv/ffmpeg is present and"
- elog "automatically pick the best option."
-
- elog
- elog "Videos or video formats streamed via RTMP protocol can only be"
- elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
- elog "Downloading MMS and RTSP videos requires either mplayer"
- elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
-}