summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/canto-daemon')
-rw-r--r--net-news/canto-daemon/Manifest2
-rw-r--r--net-news/canto-daemon/canto-daemon-0.9.8.ebuild (renamed from net-news/canto-daemon/canto-daemon-0.9.7.ebuild)24
-rw-r--r--net-news/canto-daemon/metadata.xml2
3 files changed, 20 insertions, 8 deletions
diff --git a/net-news/canto-daemon/Manifest b/net-news/canto-daemon/Manifest
index c41f450f054d..6ca71f2a0554 100644
--- a/net-news/canto-daemon/Manifest
+++ b/net-news/canto-daemon/Manifest
@@ -1 +1 @@
-DIST canto-daemon-0.9.7.tar.gz 53833 BLAKE2B 148929d610ccde11d32295b585e7ff01d847e4fbf8e9d0bea63fdf2c38b3474f958ff99a2667624b08ab90e004023659b9f4aa0477a67ed5b6e218eac4b2eedc SHA512 8c8c73cb6bc7455620abd299dfa0350ea5b8ec0e04d7ccdb1dd8ee2a6de51d0a0ba3934d66141dc899d28e49993c87002a936659f9c31b3c416ee294f9b616b9
+DIST canto-daemon-0.9.8.tar.gz 53866 BLAKE2B 55b5e9be9980df471e5488b7583be3b06f8f7048ecb3a89a64ecc9aafa806b201272bd16944a25e7a412da914cc83b76d1f19c0813366209c33195442a84586e SHA512 5394a0fea38ecbe28c02bd6f68e1e10e0523cf087bb0f79f17e53bdf8e9df16213beaa1c0a5f5873b3126022faf8d0fd999dbd01aa727c35b3c1a823501787da
diff --git a/net-news/canto-daemon/canto-daemon-0.9.7.ebuild b/net-news/canto-daemon/canto-daemon-0.9.8.ebuild
index b7c139a520be..31c5019726ce 100644
--- a/net-news/canto-daemon/canto-daemon-0.9.7.ebuild
+++ b/net-news/canto-daemon/canto-daemon-0.9.8.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="xml(+),threads(+)"
-inherit distutils-r1 multilib
+inherit distutils-r1
DESCRIPTION="Daemon part of Canto-NG RSS reader"
HOMEPAGE="https://codezen.org/canto-ng/"
SRC_URI="https://github.com/themoken/canto-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/canto-next-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
-RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+RESTRICT="test"
+PROPERTIES="test_network"
-S="${WORKDIR}/canto-next-${PV}"
+RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
python_prepare_all() {
# Respect libdir during plugins installation
@@ -25,3 +30,10 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+
+python_test() {
+ local test_file
+ for test_file in tests/*; do
+ "${EPYTHON}" "${test_file}" || die "Test ${test_file} failed with ${EPYTHON}"
+ done
+}
diff --git a/net-news/canto-daemon/metadata.xml b/net-news/canto-daemon/metadata.xml
index 05f8d200c837..f3feb6a4caf4 100644
--- a/net-news/canto-daemon/metadata.xml
+++ b/net-news/canto-daemon/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>pinkbyte@gentoo.org</email>