summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/snownews/snownews-1.5.12-r1.ebuild')
-rw-r--r--net-news/snownews/snownews-1.5.12-r1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-news/snownews/snownews-1.5.12-r1.ebuild b/net-news/snownews/snownews-1.5.12-r1.ebuild
deleted file mode 100644
index fcc9eb54801c..000000000000
--- a/net-news/snownews/snownews-1.5.12-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Snownews, a text-mode RSS/RDF newsreader"
-HOMEPAGE="https://kiza.eu/software/snownews/"
-SRC_URI="https://kiza.eu/media/software/snownews/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="unicode"
-
-COMMON_DEPEND="
- >=dev-libs/libxml2-2.5.6
- >=sys-libs/ncurses-5.3[unicode?]
- dev-libs/openssl
-"
-RDEPEND="
- ${COMMON_DEPEND}
- dev-perl/XML-LibXML
- dev-perl/libwww-perl
-"
-
-DEPEND="
- ${COMMON_DEPEND}
- virtual/pkgconfig
-"
-
-src_prepare() {
- sed -i -e "s|-O2||g" configure || die
- sed -i -e 's|$(INSTALL) -s|$(INSTALL)|g' Makefile || die
-}
-
-src_configure() {
- tc-export PKG_CONFIG
- if use unicode; then
- sed -i -e 's|-lncurses|`\\$(PKG_CONFIG) --libs ncursesw`|' configure || die
- else
- sed -i -e 's|-lncurses|`\\$(PKG_CONFIG) --libs ncurses`|' configure || die
- fi
-
- # perl script, not autotools based
- ./configure --prefix="${EPREFIX}/usr" || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- EXTRA_CFLAGS="${CFLAGS}" \
- EXTRA_LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- emake PREFIX="${ED}/usr" install
-
- dodoc AUTHOR Changelog CREDITS README README.de README.patching
-}