summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 6027cb80ae70..ba2bcfca0c12 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,3 +1,2 @@
-DIST airdcpp-webclient-2.2.1.tar.gz 845507 BLAKE2B 5d97fe5d25957d870cc5480153acb746ac20bc398e637ccf25a98e42cc905fb445bbc47c211174552e0ee23d1affb0a9265d8499389373bf6622b14428300bd5 SHA512 97c5b32e590b2fc735fe4978c1a173272c55f84fe97212f7cd1e8bd4a279553c1d992573185781aeceafbbe6bb51303ddb2cd164c748fa798993a661f3abfb81
DIST airdcpp-webclient-2.3.0.tar.gz 880508 BLAKE2B 426c0582ffad734cae2f66826aa04b2db791a110abc79629f4e3b71a69db354b56d213feae6d807f3b7a3f2906aac00fc50c49eaf3dc7d8e09783f59c99ef4e5 SHA512 b1f47c8f500aa684a8cabcff916b6a1e41230d949a35d57c80f13734f6f88f8c3a31d99f64cc1f6e316d26710da894670f130baf78fec5ecf3a70a70f0d7417a
DIST airdcpp-webclient-2.4.0.tar.gz 899040 BLAKE2B a498624fb273ecc756c6d1ce9fc6ebc4b44e0e6788ae41208a308d9e204a4657503e9123c7ed41c9a5d1ffca6a1eda54a3fdddb609244cea54b41605927281d9 SHA512 6598fd6bebae65381dd97763da4a69ce32e4d3f5cb16e5cbd66bd29d973e36c3a616138c84426c462cfd275b39b8d4bd4c0162de9dba3c02b603735ad842a3a7
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild
deleted file mode 100644
index fd8f46fe630b..000000000000
--- a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
-
-inherit cmake-utils python-any-r1 user
-
-DESCRIPTION="Cross-platform Direct Connect client"
-HOMEPAGE="https://airdcpp-web.github.io/"
-SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="nat-pmp +tbb +webui"
-
-RDEPEND="
- app-arch/bzip2
- dev-cpp/websocketpp
- dev-libs/boost:=
- dev-libs/geoip
- dev-libs/leveldb:=
- dev-libs/openssl:0=[-bindist]
- net-libs/miniupnpc:=
- sys-libs/zlib:=
- virtual/libiconv
- nat-pmp? ( net-libs/libnatpmp:= )
- tbb? ( dev-cpp/tbb:= )
-"
-DEPEND="
- virtual/pkgconfig
- ${PYTHON_DEPS}
- ${RDEPEND}
-"
-PDEPEND="webui? ( www-apps/airdcpp-webui )"
-
-pkg_setup() {
- python-any-r1_pkg_setup
- enewgroup airdcppd
- enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
-}
-
-src_configure() {
- local mycmakeargs=(
- -DINSTALL_WEB_UI=OFF
- -DENABLE_NATPMP=$(usex nat-pmp)
- -DENABLE_TBB=$(usex tbb)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- newconfd "${FILESDIR}/airdcppd.confd" airdcppd
- newinitd "${FILESDIR}/airdcppd.initd" airdcppd
- keepdir /var/lib/airdcppd
- fowners airdcppd:airdcppd /var/lib/airdcppd
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "Run 'airdcppd --configure' to set up ports and authentication"
- fi
-}