summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild')
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild
new file mode 100644
index 000000000000..4904ce462a32
--- /dev/null
+++ b/net-p2p/bitcoin-cli/bitcoin-cli-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+BITCOINCORE_NO_SYSLIBS=1
+BITCOINCORE_IUSE=""
+inherit bitcoincore
+
+DESCRIPTION="Command-line JSON-RPC client specifically designed for talking to Bitcoin Core Daemon"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+src_prepare() {
+ bitcoincore_prepare
+ sed -i 's/bitcoin-tx//' src/Makefile.am
+ bitcoincore_autoreconf
+}
+
+src_configure() {
+ bitcoincore_conf \
+ --with-utils
+}