summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild')
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
index 0ee413a509bd..95339d5b90b1 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
@@ -21,7 +21,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="+asm +bip70 +bitcoin_policy_rbf dbus kde +libevent knots libressl +qrcode test upnp +wallet zeromq"
+IUSE="+asm +bip70 dbus kde +libevent knots libressl +qrcode test upnp +wallet zeromq"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -69,14 +69,9 @@ pkg_pretend() {
elog "For more information, see:"
elog "https://bitcoincore.org/en/2018/09/18/release-${PV}/"
fi
- if use bitcoin_policy_rbf; then
- elog "Replace By Fee policy is enabled: Your node will preferentially mine and"
- elog "relay transactions paying the highest fee, regardless of receive order."
- else
- elog "Replace By Fee policy is disabled: Your node will only accept the first"
- elog "transaction seen consuming a conflicting input, regardless of fee"
- elog "offered by later ones."
- fi
+ elog "Replace By Fee policy is now always enabled by default: Your node will"
+ elog "preferentially mine and relay transactions paying the highest fee, regardless"
+ elog "of receive order. To disable RBF, set mempoolreplacement=never in bitcoin.conf"
}
src_prepare() {
@@ -98,10 +93,6 @@ src_prepare() {
eapply_user
- if ! use bitcoin_policy_rbf; then
- sed -i 's/\(DEFAULT_ENABLE_REPLACEMENT = \)true/\1false/' src/validation.h || die
- fi
-
echo '#!/bin/true' >share/genbuild.sh || die
mkdir -p src/obj || die
echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die