summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild')
-rw-r--r--net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild b/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild
index 9c14a513bc6d..c7f70686e16c 100644
--- a/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild
+++ b/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild
@@ -6,7 +6,7 @@ EAPI=5
DB_VER="4.8"
-inherit autotools db-use eutils systemd user
+inherit autotools db-use eutils flag-o-matic systemd user
MyPV="${PV/_/-}"
MyPN="litecoin"
@@ -51,6 +51,9 @@ src_prepare() {
}
src_configure() {
+ # To avoid executable GNU stack.
+ append-ldflags -Wl,-z,noexecstack
+
local my_econf=
if use upnp; then
my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"