summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild')
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild
new file mode 100644
index 000000000000..5474e996bcb5
--- /dev/null
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A torrent file parser"
+HOMEPAGE="https://github.com/Fuuzetsu/torrentinfo"
+SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-tests.patch" )
+
+python_test() {
+ nosetests test/tests.py || die "tests failed with ${EPYTHON}"
+}