summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/Manifest2
-rw-r--r--net-p2p/deluge/deluge-1.3.12.ebuild87
-rw-r--r--net-p2p/deluge/deluge-1.3.13-r2.ebuild143
-rw-r--r--net-p2p/deluge/metadata.xml2
4 files changed, 0 insertions, 234 deletions
diff --git a/net-p2p/deluge/Manifest b/net-p2p/deluge/Manifest
index 83b07cd87e00..115a834eeab2 100644
--- a/net-p2p/deluge/Manifest
+++ b/net-p2p/deluge/Manifest
@@ -1,3 +1 @@
-DIST deluge-1.3.12.tar.bz2 1772567 SHA256 565745b2a3f0567fc007dbdfeea2aa96a6bebd7dbdda2ec932a3017c66613c93 SHA512 bcb909f70d407ec766a609a1525f48b0f0ce18217049ff05dfd03b3681bdc021a446afa265b288181c644b1e47c710f41d17b1244c3b991818b947a51b97eb74 WHIRLPOOL 683e6d197ee617646ffc716738c58f479df5dc05cfc20d8295c283f9b98da309490ec582becf0d584c28a957d8bcbf1dc7b9ab4b06879d1fd338bc88a0bda29b
-DIST deluge-1.3.13.tar.bz2 1769747 SHA256 37b3a22cea3ce8b87183f5d2d972d70db6e61825ea1c6bbc052e0120c49ee8c5 SHA512 8ff904e55d0c058f456df16b8bf07ca3ead266e817435f123b34cd2a334ef1fe46baaeb95e1cce3be3f5a52768b8352ea3e61151308e9002bfb40ef872659703 WHIRLPOOL b3804d3b5fcd632388aea19a3e9aa368748aa50b7abf482d293011bae3d4c78a3a3b2879b3bb6c0cb788721794d0c3146516f67364f6c89ed42cdb358c5d1807
DIST deluge-1.3.14.tar.bz2 1774160 SHA256 c38ab40d71bf5c1b500958b2679fdfd3c45121860f1fade69b654ebd94e1ed09 SHA512 5bf37b647a84b31c4c5fa660a7a9b1f20eaac25dfe314dbc771d3ca40259e0f994ebfc6925e81902698b04291de1cae8efb0e246f1aca631bdbcdfda51b9ba42 WHIRLPOOL 76fc95acec3366f75f26e66207bb31a51f9ac55eb8882e106ca9086170973378bd796db55b2acdb70fa38467ff0f67c5822b7f0692218b4b603a2e77bf6b7ce7
diff --git a/net-p2p/deluge/deluge-1.3.12.ebuild b/net-p2p/deluge/deluge-1.3.12.ebuild
deleted file mode 100644
index 211adf6ab7f5..000000000000
--- a/net-p2p/deluge/deluge-1.3.12.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 eutils systemd
-
-DESCRIPTION="BitTorrent client with a client/server model"
-HOMEPAGE="http://deluge-torrent.org/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-2
- EGIT_REPO_URI="git://deluge-torrent.org/${PN}.git
- http://git.deluge-torrent.org/${PN}"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.bz2"
- KEYWORDS="amd64 ~arm ~ppc ~sparc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="geoip gtk libnotify setproctitle sound webinterface"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND=">=net-libs/libtorrent-rasterbar-0.14.9[python]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-util/intltool"
-RDEPEND=">=net-libs/libtorrent-rasterbar-0.14.9[python]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- >=dev-python/twisted-core-8.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-8.1[${PYTHON_USEDEP}]
- geoip? ( dev-libs/geoip )
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
- )
- setproctitle? ( dev-python/setproctitle[${PYTHON_USEDEP}] )
- webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/${PN}-1.3.5-disable_libtorrent_internal_copy.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-esetup.py() {
- # bug 531370: deluge has its own plugin system. No need to relocate its egg info files.
- # Override this call from the distutils-r1 eclass.
- # This does not respect the distutils-r1 API. DONOT copy this example.
- set -- "${PYTHON}" setup.py "$@"
- echo "$@"
- "$@" || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- newinitd "${FILESDIR}"/deluged.init deluged
- newconfd "${FILESDIR}"/deluged.conf deluged
- systemd_dounit "${FILESDIR}"/deluged.service
- systemd_dounit "${FILESDIR}"/deluge-web.service
-}
-
-pkg_postinst() {
- elog
- elog "If after upgrading it doesn't work, please remove the"
- elog "'~/.config/deluge' directory and try again, but make a backup"
- elog "first!"
- elog
- elog "To start the daemon either run 'deluged' as user"
- elog "or modify /etc/conf.d/deluged and run"
- elog "/etc/init.d/deluged start as root"
- elog "You can still use deluge the old way"
- elog
- elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
- elog
-}
diff --git a/net-p2p/deluge/deluge-1.3.13-r2.ebuild b/net-p2p/deluge/deluge-1.3.13-r2.ebuild
deleted file mode 100644
index 537cc88b26e5..000000000000
--- a/net-p2p/deluge/deluge-1.3.13-r2.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_SINGLE_IMPL=1
-PLOCALES="af ar ast be bg bn bs ca cs cy da de el en_AU en_CA en_GB eo es et eu fa fi fo fr fy ga gl he hi hr hu id is it iu ja ka kk km kn ko ku ky la lb lt lv mk ml ms nap nb nds nl nn oc pl pms pt pt_BR ro ru si sk sl sr sv ta te th tl tlh tr uk ur vi zh_CN zh_HK zh_TW"
-inherit distutils-r1 eutils systemd user l10n
-
-DESCRIPTION="BitTorrent client with a client/server model"
-HOMEPAGE="http://deluge-torrent.org/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://deluge-torrent.org/${PN}.git
- http://git.deluge-torrent.org/${PN}"
- SRC_URI=""
- KEYWORDS="amd64 x86"
-else
- SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.bz2"
- KEYWORDS="amd64 ~arm ~ppc ~sparc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="console geoip gtk libnotify sound webinterface"
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- sound? ( gtk )
- libnotify? ( gtk )
-"
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.5-disable_libtorrent_internal_copy.patch"
-)
-
-CDEPEND=">=net-libs/libtorrent-rasterbar-0.16.17[python,${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-util/intltool"
-RDEPEND="${CDEPEND}
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- (
- >=dev-python/twisted-core-13.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-13.0[${PYTHON_USEDEP}]
- )
- )
- geoip? ( dev-libs/geoip )
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
- )
- webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- local args=(
- -e "/Compiling po file/a \\\tuptoDate = False"
- )
- sed -i "${args[@]}" -- 'setup.py' || die
- args=(
- -e 's|"new_release_check": True|"new_release_check": False|'
- -e 's|"check_new_releases": True|"check_new_releases": False|'
- -e 's|"show_new_releases": True|"show_new_releases": False|'
- )
- sed -i "${args[@]}" -- 'deluge/core/preferencesmanager.py' || die
-
- local loc_dir="${S}/deluge/i18n"
- l10n_find_plocales_changes "${loc_dir}" "" ".po"
- rm_loc() {
- rm -vf "${loc_dir}/${1}.po" || die
- }
- l10n_for_each_disabled_locale_do rm_loc
-
- distutils-r1_python_prepare_all
-}
-
-esetup.py() {
- # bug 531370: deluge has its own plugin system. No need to relocate its egg info files.
- # Override this call from the distutils-r1 eclass.
- # This does not respect the distutils-r1 API. DONOT copy this example.
- set -- "${PYTHON}" setup.py "$@"
- echo "$@"
- "$@" || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if ! use console ; then
- rm -rf "${D}/usr/$(get_libdir)/python2.7/site-packages/deluge/ui/console/" || die
- rm -f "${D}/usr/bin/deluge-console" || die
- rm -f "${D}/usr/share/man/man1/deluge-console.1" ||die
- fi
- if ! use gtk ; then
- rm -rf "${D}/usr/$(get_libdir)/python2.7/site-packages/deluge/ui/gtkui/" || die
- rm -rf "${D}/usr/share/icons/" || die
- rm -f "${D}/usr/bin/deluge-gtk" || die
- rm -f "${D}/usr/share/man/man1/deluge-gtk.1" || die
- rm -f "${D}/usr/share/applications/deluge.desktop" || die
- fi
- if use webinterface; then
- newinitd "${FILESDIR}/deluge-web.init" deluge-web
- newconfd "${FILESDIR}/deluge-web.conf" deluge-web
- systemd_newunit "${FILESDIR}/deluge-web.service-2" deluge-web.service
- systemd_install_serviced "${FILESDIR}/deluge-web.service.conf"
- else
- rm -rf "${D}/usr/$(get_libdir)/python2.7/site-packages/deluge/ui/web/" || die
- rm -f "${D}/usr/bin/deluge-web" || die
- rm -f "${D}/usr/share/man/man1/deluge-web.1" || die
- fi
- newinitd "${FILESDIR}"/deluged.init-2 deluged
- newconfd "${FILESDIR}"/deluged.conf-2 deluged
- systemd_newunit "${FILESDIR}"/deluged.service-2 deluged.service
- systemd_install_serviced "${FILESDIR}"/deluged.service.conf
-}
-
-pkg_postinst() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
- elog
- elog "If, after upgrading, deluge doesn't work, please remove the"
- elog "'~/.config/deluge' directory and try again, but make a backup"
- elog "first!"
- elog
- elog "To start the daemon either run 'deluged' as user"
- elog "or modify /etc/conf.d/deluged and run"
- elog "/etc/init.d/deluged start as root"
- elog "You can still use deluge the old way"
- elog
- elog "Systemd unit files for deluged and deluge-web no longer source"
- elog "/etc/conf.d/deluge* files. Environment variable customization now"
- elog "happens in /etc/systemd/system/deluged.service.d/00gentoo.conf"
- elog "and /etc/systemd/system/deluge-web.service.d/00gentoo.conf"
- elog
- elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
- elog
-}
diff --git a/net-p2p/deluge/metadata.xml b/net-p2p/deluge/metadata.xml
index d59b3c43b4e6..33afb6123b98 100644
--- a/net-p2p/deluge/metadata.xml
+++ b/net-p2p/deluge/metadata.xml
@@ -16,8 +16,6 @@
<name>Gentoo Proxy Maintainers Project</name>
</maintainer>
<use>
- <flag name="setproctitle">Install dependencies needed for beautifying
- the process name</flag>
<flag name="webinterface">Install dependencies needed for the web
interface</flag>
<flag name="console">Enable default console UI</flag>