summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/htun/files')
-rw-r--r--net-vpn/htun/files/README.gentoo3
-rw-r--r--net-vpn/htun/files/htun-0.9.6-glibc.patch14
-rw-r--r--net-vpn/htun/files/htun-0.9.6-makefile.patch34
3 files changed, 0 insertions, 51 deletions
diff --git a/net-vpn/htun/files/README.gentoo b/net-vpn/htun/files/README.gentoo
deleted file mode 100644
index 1710c726723a..000000000000
--- a/net-vpn/htun/files/README.gentoo
+++ /dev/null
@@ -1,3 +0,0 @@
-NOTE: HTun requires the Universal TUN/TAP module
-available in the Linux kernel. Make sure you have
-compiled the tun.o driver as a module!
diff --git a/net-vpn/htun/files/htun-0.9.6-glibc.patch b/net-vpn/htun/files/htun-0.9.6-glibc.patch
deleted file mode 100644
index 3f281c526388..000000000000
--- a/net-vpn/htun/files/htun-0.9.6-glibc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-get things building with glibc-2.8
-
-http://bugs.gentoo.org/248100
-
---- a/include/common.h
-+++ b/include/common.h
-@@ -23,6 +23,7 @@
- #ifndef __COMMON_H
- #define __COMMON_H
-
-+#include <limits.h>
- #include <netinet/in.h>
- #include <time.h>
- #include "queue.h"
diff --git a/net-vpn/htun/files/htun-0.9.6-makefile.patch b/net-vpn/htun/files/htun-0.9.6-makefile.patch
deleted file mode 100644
index c1f0b76bfa14..000000000000
--- a/net-vpn/htun/files/htun-0.9.6-makefile.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-* Fix build system to not hardcode CC
-* Fix build system to respect user flags
-
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -20,16 +20,14 @@
-
- # $Id: Makefile,v 2.16 2002/08/11 15:57:07 jehsom Exp $
-
--
--CFLAGS = -I../include -I. -O -W -Wall -g -D_REENTRANT #-pg -a
--LDFLAGS = -lfl -lpthread # -flex for linux, solaris ?
--LEX_CFLAGS = -I../include -I. -g -D_REENTRANT #-pg -a
-+CFLAGS := $(CFLAGS) -I../include -I. -O -W -Wall -D_REENTRANT
-+LDFLAGS := $(LDFLAGS) -lfl -lpthread
-+LEX_CFLAGS = -I../include -I. -D_REENTRANT
-
- # in Linux, LFLAGS is empty. In Solaris, LFLAGS = -lnsl -lsocket
- #LFLAGS = -lnsl -lsocket
-
- VPATH = .:../include
--CC := gcc
- LEX = flex
- YACC = yacc
- INCLUDE := $(wildcard ../include/*.h)
-@@ -52,7 +50,7 @@
- $(OBJS): $(INCLUDE)
-
- $(CONFOBS): $(CONFSRC)
-- $(CC) $(LEX_CFLAGS) -c $(@:.o=.c)
-+ $(CC) $(CFLAGS) $(LEX_CFLAGS) -c $(@:.o=.c)
-
- lex.yy.c: parse.l
- $(LEX) $^