summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0.ebuild')
-rw-r--r--net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0.ebuild b/net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0.ebuild
new file mode 100644
index 000000000000..326be8e253f3
--- /dev/null
+++ b/net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="A sub-package that adds OpenCL-capability to Pyrit"
+HOMEPAGE="http://code.google.com/p/pyrit/"
+SRC_URI="http://pyrit.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/openssl
+ sys-libs/zlib
+ virtual/opencl"
+RDEPEND="${DEPEND}"
+PDEPEND="~net-wireless/pyrit-${PV}"