summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-ppm-wiegand/gr-ppm-wiegand-9999.ebuild')
-rw-r--r--net-wireless/gr-ppm-wiegand/gr-ppm-wiegand-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-wireless/gr-ppm-wiegand/gr-ppm-wiegand-9999.ebuild b/net-wireless/gr-ppm-wiegand/gr-ppm-wiegand-9999.ebuild
new file mode 100644
index 000000000000..793f5725988b
--- /dev/null
+++ b/net-wireless/gr-ppm-wiegand/gr-ppm-wiegand-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="GnuRadio PPM (Differential Pulse Position Modulation/Demodulation) plugin"
+HOMEPAGE="https://github.com/redsand/gr-ppm-wiegand"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/redsand/gr-ppm-wiegand.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/redsand/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ >=net-wireless/gnuradio-3.7.0:="
+
+DEPEND="${RDEPEND}
+ dev-libs/boost:=
+ dev-util/cppunit"