summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/kismet-ubertooth')
-rw-r--r--net-wireless/kismet-ubertooth/Manifest1
-rw-r--r--net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.1.ebuild53
-rw-r--r--net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild4
3 files changed, 56 insertions, 2 deletions
diff --git a/net-wireless/kismet-ubertooth/Manifest b/net-wireless/kismet-ubertooth/Manifest
index fdbdd182bc20..e10d29d38e3c 100644
--- a/net-wireless/kismet-ubertooth/Manifest
+++ b/net-wireless/kismet-ubertooth/Manifest
@@ -1,2 +1,3 @@
DIST ubertooth-2015-09-R2.tar.xz 1706712 SHA256 f2088c8c0e754df47dd8dbf604d5822bf5894b91e4505276c6f9e26b6a23b56d SHA512 240f6d682fe0addc05bb8ccf7eec931534449adfa9c1369b484aeac73d9bcaf75c211aeede21c6c219e363773ce3d63e4aa0ee6b662acc83409587bd7ac7e4da WHIRLPOOL 9fba78d1740efd342f3892ffc3cf914d1919ef1c7d282786a64afb72d6ed306dec3600363e3f85f2f70d9ccfba6b62f826a72942cb7c9316d151dd2718f79b09
DIST ubertooth-2015-10-R1.tar.xz 1716840 SHA256 bc37e7978d137a64d918d7c8f1e7ca9cff093f9921d805e9809b12e5ab12ae35 SHA512 ad7229c9509db4b4230ec28d1c16200f0780dd7ce55224528ced6d8969f342a79b7317b69e7b9e49d03e93f973203801f4f703dd80dc115400366b0984c965b1 WHIRLPOOL 5f46bdc8746481d68fd5c8e3ce04aadbcc1bc704c95b1b5a3d389376704a2a3e702faf819c749f98cb737578e9ccfa3ac01887081bceeceed2e4804493b2c2a8
+DIST ubertooth-2017-03-R1.tar.xz 671196 SHA256 76ace37e3920c0216b13aa7c0a4c094864262f1054f5ac406beafde954a37726 SHA512 546cc84b2c322e48c7a9da5c507b213d7fe6e8c1fefde0404f9bbc1f24675ace7fc831f941f362eca2cf3abefe1d9ba51cb12dd8b7407a59b7560fba8864b268 WHIRLPOOL e8229d522de78fb752a3ada37083753ea413b92426907cabc50575b48a00b445c25a7a78447b24196840cb655961d1ff4cb5c3e4462ff2893f31848fe15c102f
diff --git a/net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.1.ebuild b/net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.1.ebuild
new file mode 100644
index 000000000000..1ed24b3efdb0
--- /dev/null
+++ b/net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ S="${WORKDIR}/ubertooth-${MY_PV}"
+ SRC_URI="https://github.com/greatscottgadgets/ubertooth/releases/download/${MY_PV}/ubertooth-${MY_PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Provides basic bluetooth support in kismet"
+HOMEPAGE="http://ubertooth.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND=">=net-wireless/kismet-2011.03.2-r1:= \
+ >=net-wireless/ubertooth-${PV}:= \
+ >=net-libs/libbtbb-${PV}:= \
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if has_version =net-wireless/kismet-9999; then
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
+ else
+ cd "${S}/host/kismet/plugin-ubertooth" || die
+ fi
+ emake KIS_SRC_DIR="/usr/include/kismet/"
+}
+
+src_install() {
+ if has_version =net-wireless/kismet-9999; then
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
+ else
+ cd "${S}/host/kismet/plugin-ubertooth" || die
+ fi
+ emake DESTDIR="${ED}" LIBDIR="/$(get_libdir)" KIS_SRC_DIR="/usr/include/kismet/" install
+}
+
+pkg_postinst() {
+ ewarn "This package must be rebuilt every time kismet is rebuilt. Or else."
+}
diff --git a/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild b/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild
index 5f3e212e2e60..1ed24b3efdb0 100644
--- a/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild
+++ b/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit multilib