summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/yatebts/files')
-rw-r--r--net-wireless/yatebts/files/yatebts-4.0.0-dont-mess-with-cflags.patch13
-rw-r--r--net-wireless/yatebts/files/yatebts-bladeRF-transceiver_revert_init_order.patch86
-rw-r--r--net-wireless/yatebts/files/yatebts-sgsnggsn-inetutils-hostname-fix.diff14
3 files changed, 113 insertions, 0 deletions
diff --git a/net-wireless/yatebts/files/yatebts-4.0.0-dont-mess-with-cflags.patch b/net-wireless/yatebts/files/yatebts-4.0.0-dont-mess-with-cflags.patch
new file mode 100644
index 000000000000..b10eb57237ef
--- /dev/null
+++ b/net-wireless/yatebts/files/yatebts-4.0.0-dont-mess-with-cflags.patch
@@ -0,0 +1,13 @@
+diff -Naur yate-bts/configure.in yate-bts-sane/configure.in
+--- yate-bts/configure.in 2014-07-25 10:28:44.000000000 -0400
++++ yate-bts-sane/configure.in 2014-07-25 17:38:23.550069064 -0400
+@@ -36,9 +36,6 @@
+ AC_PROG_CC
+ AC_PROG_AWK
+
+-# Delete -g as we handle debug info at build time
+-CFLAGS=`echo "$CFLAGS" | sed 's/-g[[0-9]]* *//' 2>/dev/null`
+-
+ # Helper to check by pkgconfig including local paths
+ function pkgconfig_check()
+ {
diff --git a/net-wireless/yatebts/files/yatebts-bladeRF-transceiver_revert_init_order.patch b/net-wireless/yatebts/files/yatebts-bladeRF-transceiver_revert_init_order.patch
new file mode 100644
index 000000000000..83da1d58d29d
--- /dev/null
+++ b/net-wireless/yatebts/files/yatebts-bladeRF-transceiver_revert_init_order.patch
@@ -0,0 +1,86 @@
+diff --git a/mbts/TransceiverRAD1/bladeRFDevice.cpp b/mbts/TransceiverRAD1/bladeRFDevice.cpp
+index a2a3346..cfdb977 100644
+--- a/mbts/TransceiverRAD1/bladeRFDevice.cpp
++++ b/mbts/TransceiverRAD1/bladeRFDevice.cpp
+@@ -35,7 +35,6 @@
+
+ #include <Logger.h>
+
+-
+ #define MIN_OVERSAMPLING 4
+
+ #define HEALTH_BAD 10
+@@ -128,7 +127,36 @@ bool bladeRFDevice::open(const std::string &args, bool)
+ << "." << ver.patch << " (" << ver.describe << ")";
+
+ uint32_t val = 0;
+- bladerf_config_gpio_read(bdev, &val);
++
++ status = bladerf_sync_config(bdev,
++ BLADERF_MODULE_RX,
++ BLADERF_FORMAT_SC16_Q11,
++ DEFAULT_STREAM_RX_BUFFERS,
++ DEFAULT_STREAM_SAMPLES,
++ DEFAULT_STREAM_RX_XFERS,
++ DEFAULT_STREAM_TIMEOUT
++ );
++
++ if (status < 0) {
++ LOG(CRIT) << "Failed to intialize RX sync handle: " << bladerf_strerror(status);
++ checkHealth(mRxHealth, false);
++ }
++
++ status = bladerf_sync_config(bdev,
++ BLADERF_MODULE_TX,
++ BLADERF_FORMAT_SC16_Q11,
++ DEFAULT_STREAM_TX_BUFFERS,
++ DEFAULT_STREAM_SAMPLES,
++ DEFAULT_STREAM_TX_XFERS,
++ DEFAULT_STREAM_TIMEOUT
++ );
++
++ if (status < 0) {
++ LOG(CRIT) << "Failed to intialize TX sync handle: " << bladerf_strerror(status);
++ checkHealth(mTxHealth, false);
++ }
++
++ bladerf_config_gpio_read(bdev, &val);
+ val |= 0x10000; //enable timestamps, clears and resets everything on write
+ bladerf_config_gpio_write(bdev, val);
+ bladerf_config_gpio_read(bdev, &val);
+@@ -185,34 +213,6 @@ bool bladeRFDevice::open(const std::string &args, bool)
+ else
+ LOG(INFO) << "Actual bandwidth " << bw;
+
+- status = bladerf_sync_config(bdev,
+- BLADERF_MODULE_RX,
+- BLADERF_FORMAT_SC16_Q11,
+- DEFAULT_STREAM_RX_BUFFERS,
+- DEFAULT_STREAM_SAMPLES,
+- DEFAULT_STREAM_RX_XFERS,
+- DEFAULT_STREAM_TIMEOUT
+- );
+-
+- if (status < 0) {
+- LOG(CRIT) << "Failed to intialize RX sync handle: " << bladerf_strerror(status);
+- checkHealth(mRxHealth, false);
+- }
+-
+- status = bladerf_sync_config(bdev,
+- BLADERF_MODULE_TX,
+- BLADERF_FORMAT_SC16_Q11,
+- DEFAULT_STREAM_TX_BUFFERS,
+- DEFAULT_STREAM_SAMPLES,
+- DEFAULT_STREAM_TX_XFERS,
+- DEFAULT_STREAM_TIMEOUT
+- );
+-
+- if (status < 0) {
+- LOG(CRIT) << "Failed to intialize TX sync handle: " << bladerf_strerror(status);
+- checkHealth(mTxHealth, false);
+- }
+-
+ mRxGain1 = BLADERF_RXVGA1_GAIN_MAX;
+ mDcCorrect = true;
+ mRxMaxOffset = RX_OFFSET_ERROR * RX_AVERAGE_DAMPING;
+
diff --git a/net-wireless/yatebts/files/yatebts-sgsnggsn-inetutils-hostname-fix.diff b/net-wireless/yatebts/files/yatebts-sgsnggsn-inetutils-hostname-fix.diff
new file mode 100644
index 000000000000..46b4b1d1ba4d
--- /dev/null
+++ b/net-wireless/yatebts/files/yatebts-sgsnggsn-inetutils-hostname-fix.diff
@@ -0,0 +1,14 @@
+diff --git a/mbts/SGSNGGSN/iputils.cpp b/mbts/SGSNGGSN/iputils.cpp
+index 979ae3a..49bb0ff 100644
+--- a/mbts/SGSNGGSN/iputils.cpp
++++ b/mbts/SGSNGGSN/iputils.cpp
+@@ -466,7 +466,7 @@ EXPORT uint32_t *ip_findmyaddr()
+ const int maxaddrs = 5;
+ static uint32_t addrs[maxaddrs+1];
+ int n = 0;
+- int fd = runcmd("|/bin/hostname","hostname","-I", NULL);
++ int fd = runcmd("|/bin/hostname","hostname","-i", NULL);
+ if (fd < 0) {
+ failed:
+ addrs[0] = (unsigned) -1; // converts to all 1s
+