summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ros-meta/executive_smach/executive_smach-2.0.1.ebuild')
-rw-r--r--ros-meta/executive_smach/executive_smach-2.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/ros-meta/executive_smach/executive_smach-2.0.1.ebuild b/ros-meta/executive_smach/executive_smach-2.0.1.ebuild
new file mode 100644
index 000000000000..7d06703beb4f
--- /dev/null
+++ b/ros-meta/executive_smach/executive_smach-2.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="SMACH library and ROS SMACH integration packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/smach
+ dev-ros/smach_ros
+ dev-ros/smach_msgs
+"
+DEPEND="${RDEPEND}"