summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ros-meta/ros/ros-1.14.1.ebuild')
-rw-r--r--ros-meta/ros/ros-1.14.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/ros-meta/ros/ros-1.14.1.ebuild b/ros-meta/ros/ros-1.14.1.ebuild
new file mode 100644
index 000000000000..23b1459f6f33
--- /dev/null
+++ b/ros-meta/ros/ros-1.14.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=ros
+
+inherit ros-catkin
+
+DESCRIPTION="ROS packaging system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbash
+ dev-ros/rosboost_cfg
+ dev-ros/rosclean
+ dev-ros/roscreate
+ dev-ros/rosmake
+ dev-ros/rosunit
+
+ dev-ros/mk
+ dev-ros/rosbuild
+ dev-ros/roslang
+ dev-ros/roslib
+"
+DEPEND="${RDEPEND}"