summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/montage/montage-5.0.ebuild')
-rw-r--r--sci-astronomy/montage/montage-5.0.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sci-astronomy/montage/montage-5.0.ebuild b/sci-astronomy/montage/montage-5.0.ebuild
index d426c00c3c12..850a2ff98dc4 100644
--- a/sci-astronomy/montage/montage-5.0.ebuild
+++ b/sci-astronomy/montage/montage-5.0.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs flag-o-matic
MYPN=Montage
-
DESCRIPTION="Toolkit for assembling FITS images into mosaics"
HOMEPAGE="http://montage.ipac.caltech.edu/"
SRC_URI="http://montage.ipac.caltech.edu/download/${MYPN}_v${PV}.tar.gz"
+S="${WORKDIR}/${MYPN}"
LICENSE="BSD GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
-
IUSE="doc mpi"
RDEPEND="
@@ -31,10 +30,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.0-fix_freetype_incude.patch
)
-S="${WORKDIR}/${MYPN}"
-
src_prepare() {
default
+
sed -e '/cfitsio/d' \
-e '/wcssubs/d' \
-e '/jpeg/d' \
@@ -43,6 +41,9 @@ src_prepare() {
tc-export CC AR
+ # bug #708396
+ append-cflags -fcommon
+
find . -name Makefile\* | xargs sed -i \
-e "/^CC.*=/s:\(gcc\|cc\):$(tc-getCC):g" \
-e "/^CFLAGS.*=/s:-g:${CFLAGS} $($(tc-getPKG_CONFIG) --cflags wcstools):g" \