summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/clustalx/clustalx-2.1-r2.ebuild')
-rw-r--r--sci-biology/clustalx/clustalx-2.1-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-biology/clustalx/clustalx-2.1-r2.ebuild b/sci-biology/clustalx/clustalx-2.1-r2.ebuild
new file mode 100644
index 000000000000..65e9341a3810
--- /dev/null
+++ b/sci-biology/clustalx/clustalx-2.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Graphical interface for the ClustalW multiple alignment program"
+HOMEPAGE="http://www.ebi.ac.uk/tools/clustalw2/"
+SRC_URI="
+ http://www.clustal.org/download/current/${P}.tar.gz
+ https://dev.gentoo.org/~jlec/distfiles/${PN}.png.xz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ >=sci-biology/clustalw-${PV}"
+
+src_prepare() {
+ sed \
+ -e "s|colprot.xml|${EPREFIX}/usr/share/${PN}/colprot.xml|" \
+ -e "s|coldna.xml|${EPREFIX}/usr/share/${PN}/coldna.xml|" \
+ -e "s|colprint.xml|${EPREFIX}/usr/share/${PN}/colprint.xml|" \
+ -i ClustalQtParams.h || \
+ die "Failed to patch shared files location."
+ sed \
+ -e "s|clustalx.hlp|${EPREFIX}/usr/share/${PN}/clustalx.hlp|" \
+ -i HelpDisplayWidget.cpp || \
+ die "Failed to patch help file location."
+ rm -rf usr || die
+ default
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dobin clustalx
+ insinto /usr/share/${PN}
+ doins colprot.xml coldna.xml colprint.xml clustalx.hlp
+ make_desktop_entry ${PN} ClustalX
+ doicon "${WORKDIR}"/${PN}.png
+}