summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/embassy-phylipnew')
-rw-r--r--sci-biology/embassy-phylipnew/Manifest3
-rw-r--r--sci-biology/embassy-phylipnew/embassy-phylipnew-3.67.ebuild14
-rw-r--r--sci-biology/embassy-phylipnew/embassy-phylipnew-3.69.650.ebuild17
-rw-r--r--sci-biology/embassy-phylipnew/files/embassy-phylipnew-3.69.650_fix-build-system.patch111
-rw-r--r--sci-biology/embassy-phylipnew/metadata.xml5
5 files changed, 150 insertions, 0 deletions
diff --git a/sci-biology/embassy-phylipnew/Manifest b/sci-biology/embassy-phylipnew/Manifest
new file mode 100644
index 000000000000..638f9da73ac0
--- /dev/null
+++ b/sci-biology/embassy-phylipnew/Manifest
@@ -0,0 +1,3 @@
+DIST EMBOSS-6.0.1.tar.gz 20204153 SHA256 3e352902aa9dab88bf486457ff23794f19398dfc6b550c4bf175dfcad34c233d
+DIST embassy-6.0.1-phylipnew-3.67.tar.gz 1624802 SHA256 efbfdbff0109c62823caf13f20cb6462f54371d55899fcbbe29240e503584945
+DIST embassy-phylipnew-3.69.650.tar.gz 1741298 SHA256 af385d01826e67e05295955f05721728abbd4feb9e11a944189414da6590bfeb SHA512 b41a31285e05a418e4fbfae7241c3658fe458e3d5d84bff472d98b7c145340a55bee1d744b5c056d0e88407074947b5f37b2182c9cb800c8a8d43dfa76d026d5 WHIRLPOOL 94cbe384a1575c322c7e3cdba7ccdb79e3e24cec7bd24776872f3e7d425d85c64fdcdc1cae6c079b40ca943b84a039ba2c7c5c059c40ceaf95c5c2e11e4a3e58
diff --git a/sci-biology/embassy-phylipnew/embassy-phylipnew-3.67.ebuild b/sci-biology/embassy-phylipnew/embassy-phylipnew-3.67.ebuild
new file mode 100644
index 000000000000..2bc4a956502f
--- /dev/null
+++ b/sci-biology/embassy-phylipnew/embassy-phylipnew-3.67.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EBOV="6.0.1"
+
+inherit embassy
+
+DESCRIPTION="EMBOSS integrated version of PHYLIP - The Phylogeny Inference Package"
+LICENSE="freedist"
+SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/old/${EBOV}/EMBOSS-${EBOV}.tar.gz
+ mirror://gentoo/embassy-${EBOV}-${PN:8}-${PV}.tar.gz"
+
+KEYWORDS="amd64 ~ppc x86"
diff --git a/sci-biology/embassy-phylipnew/embassy-phylipnew-3.69.650.ebuild b/sci-biology/embassy-phylipnew/embassy-phylipnew-3.69.650.ebuild
new file mode 100644
index 000000000000..18b8b33c91fb
--- /dev/null
+++ b/sci-biology/embassy-phylipnew/embassy-phylipnew-3.69.650.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EBO_DESCRIPTION="The Phylogeny Inference Package"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit emboss-r1
+
+LICENSE+=" freedist"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos"
+
+PATCHES=( "${FILESDIR}"/${P}_fix-build-system.patch )
diff --git a/sci-biology/embassy-phylipnew/files/embassy-phylipnew-3.69.650_fix-build-system.patch b/sci-biology/embassy-phylipnew/files/embassy-phylipnew-3.69.650_fix-build-system.patch
new file mode 100644
index 000000000000..1cba944094a2
--- /dev/null
+++ b/sci-biology/embassy-phylipnew/files/embassy-phylipnew-3.69.650_fix-build-system.patch
@@ -0,0 +1,111 @@
+ configure.ac | 49 +++++++------------------------------------------
+ emboss_acd/Makefile.am | 2 +-
+ src/Makefile.am | 7 ++-----
+ 3 files changed, 10 insertions(+), 48 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e5bfaf1..09ed517 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -635,33 +635,6 @@ AS_CASE([${host_os}],
+
+
+
+-dnl PCRE library definitions - see the MAJOR and MINOR values
+-dnl to see which version's configure.in these lines come from
+-
+-dnl Provide the current PCRE version information. Do not use numbers
+-dnl with leading zeros for the minor version, as they end up in a C
+-dnl macro, and may be treated as octal constants. Stick to single
+-dnl digits for minor numbers less than 10. There are unlikely to be
+-dnl that many releases anyway.
+-
+-PCRE_MAJOR="7"
+-PCRE_MINOR="9"
+-PCRE_DATE="11-Apr-2009"
+-PCRE_VERSION="${PCRE_MAJOR}.${PCRE_MINOR}"
+-
+-dnl Default values for miscellaneous macros
+-
+-POSIX_MALLOC_THRESHOLD="-DPOSIX_MALLOC_THRESHOLD=10"
+-
+-dnl Provide versioning information for libtool shared libraries that
+-dnl are built by default on Unix systems.
+-
+-PCRE_LIB_VERSION="0:1:0"
+-PCRE_POSIXLIB_VERSION="0:0:0"
+-
+-
+-
+-
+ dnl FIXME: This does no longer seem required with Autoconf 2.67?
+ dnl Intel MacOSX 10.6 puts X11 in a non-standard place
+ dnl AS_IF([test "x${with_x}" != "xno"],
+@@ -781,21 +754,6 @@ AX_LIB_POSTGRESQL
+
+
+
+-dnl "Export" these variables for PCRE
+-
+-AC_SUBST([HAVE_MEMMOVE])
+-AC_SUBST([HAVE_STRERROR])
+-AC_SUBST([PCRE_MAJOR])
+-AC_SUBST([PCRE_MINOR])
+-AC_SUBST([PCRE_DATE])
+-AC_SUBST([PCRE_VERSION])
+-AC_SUBST([PCRE_LIB_VERSION])
+-AC_SUBST([PCRE_POSIXLIB_VERSION])
+-AC_SUBST([POSIX_MALLOC_THRESHOLD])
+-
+-
+-
+-
+ dnl Test if --enable-localforce given
+ locallink="no"
+ embprefix="/usr/local"
+@@ -918,6 +876,13 @@ AC_ARG_ENABLE([systemlibs],
+ AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
+
+
++AS_IF([test "x${enable_systemlibs}" = "xyes"],
++[
++dnl using system libraries
++ PKG_CHECK_MODULES([PLPLOT], [plplotd],
++ [],[PKG_CHECK_MODULES([PLPLOT], [plplot])]
++ )
++])
+
+
+ # Enable the purify tool: --enable-purify, sets CC and LIBTOOL
+diff --git a/emboss_acd/Makefile.am b/emboss_acd/Makefile.am
+index e1c1878..e253c95 100644
+--- a/emboss_acd/Makefile.am
++++ b/emboss_acd/Makefile.am
+@@ -1,3 +1,3 @@
+
+-pkgdata_DATA = *.acd
++pkgdata_DATA = $(srcdir)/*.acd
+ pkgdatadir=$(prefix)/share/EMBOSS/acd
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 1883ce9..fb1787f 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -16,10 +16,7 @@ AM_CPPFLAGS = -I../include -I../../../nucleus -I../../../ajax/pcre \
+ -I../../../ajax/ensembl -I../../../ajax/ajaxdb \
+ -I../../../ajax/acd -I../../../plplot
+ else
+-AM_CPPFLAGS = -I../include -I${embprefix}/include \
+- -I${embprefix}/include/eplplot \
+- $(NLINCLUDES) \
+- -I${embprefix}/include/epcre
++AM_CPPFLAGS = -I$(top_srcdir)/include -I${embprefix}/include $(NLINCLUDES) $(PLPLOT_CFLAGS)
+ endif
+
+ if ISSHARED
+@@ -120,5 +117,5 @@ LDADD = ../../../nucleus/libnucleus.la ../../../ajax/acd/libacd.la \
+ ../../../plplot/libeplplot.la $(XLIB)
+ else
+ LDADD = -L${embprefix}/lib -lnucleus -lacd -lajaxdb -lensembl -lajaxg \
+- -lajax -lepcre $(NLADD) -leplplot $(XLIB)
++ -lajax $(NLADD) $(XLIB)
+ endif
diff --git a/sci-biology/embassy-phylipnew/metadata.xml b/sci-biology/embassy-phylipnew/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/embassy-phylipnew/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>