summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/hmmer')
-rw-r--r--sci-biology/hmmer/Manifest2
-rw-r--r--sci-biology/hmmer/files/hmmer-3.0-fix_tests.patch23
-rw-r--r--sci-biology/hmmer/files/hmmer-3.0-perl-5.16-2.patch132
-rw-r--r--sci-biology/hmmer/hmmer-2.3.2-r1.ebuild51
-rw-r--r--sci-biology/hmmer/hmmer-2.3.2-r2.ebuild51
-rw-r--r--sci-biology/hmmer/hmmer-3.0.ebuild45
-rw-r--r--sci-biology/hmmer/metadata.xml9
7 files changed, 313 insertions, 0 deletions
diff --git a/sci-biology/hmmer/Manifest b/sci-biology/hmmer/Manifest
new file mode 100644
index 000000000000..4ab0094769a2
--- /dev/null
+++ b/sci-biology/hmmer/Manifest
@@ -0,0 +1,2 @@
+DIST hmmer-2.3.2.tar.gz 1024933 SHA256 d20e1779fcdff34ab4e986ea74a6c4ac5c5f01da2993b14e92c94d2f076828b4
+DIST hmmer-3.0.tar.gz 3952015 SHA256 6977e6473fcb554b1d5a86dc9edffffa53918c1bd88d7fd20d7499f1ba719e83
diff --git a/sci-biology/hmmer/files/hmmer-3.0-fix_tests.patch b/sci-biology/hmmer/files/hmmer-3.0-fix_tests.patch
new file mode 100644
index 000000000000..983827b0bd46
--- /dev/null
+++ b/sci-biology/hmmer/files/hmmer-3.0-fix_tests.patch
@@ -0,0 +1,23 @@
+--- easel/Makefile.in
++++ easel/Makefile.in
+@@ -26,8 +26,7 @@
+ LDFLAGS = @LDFLAGS@
+ SIMDFLAGS= @SIMD_CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
+-LIBGSL = @LIBGSL@
+-LIBS = @LIBS@ @PTHREAD_LIBS@
++LIBS = @LIBS@ @LIBGSL@ @PTHREAD_LIBS@
+
+ # Other tools
+ #
+@@ -252,8 +251,8 @@
+ else \
+ DFILE=${srcdir}/esl_$${BASENAME}.c ;\
+ fi;\
+- echo ${CC} ${CFLAGS} ${SIMDFLAGS} ${DEFS} ${LDFLAGS} -o $@ -I. -I${srcdir} -L. -D$${DFLAG} $${DFILE} -leasel -lm;\
+- ${CC} ${CFLAGS} ${SIMDFLAGS} ${DEFS} ${LDFLAGS} -o $@ -I. -I${srcdir} -L. -D$${DFLAG} $${DFILE} -leasel -lm
++ echo ${CC} ${CFLAGS} ${SIMDFLAGS} ${DEFS} ${LDFLAGS} -o $@ -I. -I${srcdir} -L. -D$${DFLAG} $${DFILE} -leasel -lm ${LIBS};\
++ ${CC} ${CFLAGS} ${SIMDFLAGS} ${DEFS} ${LDFLAGS} -o $@ -I. -I${srcdir} -L. -D$${DFLAG} $${DFILE} -leasel -lm ${LIBS}
+
+
+ # install: installs libeasel.a in ${libdir}/
diff --git a/sci-biology/hmmer/files/hmmer-3.0-perl-5.16-2.patch b/sci-biology/hmmer/files/hmmer-3.0-perl-5.16-2.patch
new file mode 100644
index 000000000000..19d38c8e32ed
--- /dev/null
+++ b/sci-biology/hmmer/files/hmmer-3.0-perl-5.16-2.patch
@@ -0,0 +1,132 @@
+ easel/devkit/autodoc | 4 ++--
+ easel/devkit/esl-dependencies | 4 ++--
+ easel/devkit/sqc | 7 +++----
+ easel/testsuite/coverage_report.pl | 4 ++--
+ easel/testsuite/driver_report.pl | 4 ++--
+ easel/testsuite/valgrind_report.pl | 4 ++--
+ profmark/rocplot.pl | 4 ++--
+ 7 files changed, 15 insertions(+), 16 deletions(-)
+
+diff --git a/easel/devkit/autodoc b/easel/devkit/autodoc
+index 16bda4d..f5c5efc 100755
+--- a/easel/devkit/autodoc
++++ b/easel/devkit/autodoc
+@@ -49,8 +49,8 @@
+ #
+ # SRE, Tue Nov 30 19:43:47 2004
+
+-require "getopts.pl";
+-&Getopts('n:t');
++use Getopt::Std;
++getopts('n:t');
+ $cfile = shift;
+
+ if ($opt_t) { $show_api_table = 1; }
+diff --git a/easel/devkit/esl-dependencies b/easel/devkit/esl-dependencies
+index a4dc126..b61fa7a 100755
+--- a/easel/devkit/esl-dependencies
++++ b/easel/devkit/esl-dependencies
+@@ -13,8 +13,8 @@
+ # SRE, Mon Jun 11 11:15:31 2007
+ # SVN $Id$
+
+-require "getopts.pl"
+-&Getopts('1afr');
++use Getopt::Std;
++getopts('1afr');
+
+ if ($opt_1) { $show_summary_table = 1; }
+ if ($opt_a) { $list_augfiles = 1; }
+diff --git a/easel/devkit/sqc b/easel/devkit/sqc
+index af3adf6..0cdb458 100755
+--- a/easel/devkit/sqc
++++ b/easel/devkit/sqc
+@@ -205,12 +205,11 @@
+ # SRE, Tue Aug 6 11:16:39 2002
+ # SVN $Id: sqc 1796 2007-01-03 22:36:44Z eddys $
+
+-require "getopts.pl";
+-require "importenv.pl";
++use Getopt::Std;
+
+ # Parse our command line
+ #
+-&Getopts('v');
++getopts('v');
+ if ($opt_v) { $verbose = 1; }
+
+
+@@ -609,7 +608,7 @@ sub check_valgrind_status
+ #
+ sub tempname {
+ my ($dir, $name, $suffix);
+- if ($TMPDIR) { $dir = $TMPDIR."/"; } else {$dir = "";}
++ if ($ENV{TMPDIR}) { $dir = $ENV{TMPDIR}."/"; } else {$dir = "";}
+
+ foreach $suffix ("aa".."zz") {
+ $name = "$dir"."esltmp".$suffix.$$;
+diff --git a/easel/testsuite/coverage_report.pl b/easel/testsuite/coverage_report.pl
+old mode 100755
+new mode 100644
+index 9c77791..024ed34
+--- a/easel/testsuite/coverage_report.pl
++++ b/easel/testsuite/coverage_report.pl
+@@ -16,9 +16,9 @@
+ #
+ # SRE, Thu Mar 1 19:22:57 2007 (Janelia)
+ # SVN $Id: coverage_report.pl 231 2008-03-25 14:43:57Z eddys $
+-require "getopts.pl";
++use Getopt::Std;
+ $have_sloccount = 1;
+-&Getopts('cs');
++getopts('cs');
+ if ($opt_c) { $do_recompile = 1; }
+ if ($opt_s) { $have_sloccount = 0; }
+
+diff --git a/easel/testsuite/driver_report.pl b/easel/testsuite/driver_report.pl
+index 757854d..a9a8902 100755
+--- a/easel/testsuite/driver_report.pl
++++ b/easel/testsuite/driver_report.pl
+@@ -25,8 +25,8 @@
+ # SRE, Fri Mar 2 10:01:44 2007 (Janelia)
+ # SVN $Id: driver_report.pl 326 2009-02-28 15:49:07Z eddys $
+
+-require "getopts.pl";
+-&Getopts('c');
++use Getopt::Std;
++getopts('c');
+ if ($opt_c) { $do_recompile = 1; }
+
+ if ($ENV{'CC'} ne "") { $CC = $ENV{'CC'}; } else { $CC = "gcc"; }
+diff --git a/easel/testsuite/valgrind_report.pl b/easel/testsuite/valgrind_report.pl
+old mode 100755
+new mode 100644
+index 186a392..07026a0
+--- a/easel/testsuite/valgrind_report.pl
++++ b/easel/testsuite/valgrind_report.pl
+@@ -10,8 +10,8 @@
+ #
+ # SRE, Fri Mar 2 08:37:48 2007 [Janelia]
+ # SVN $Id: valgrind_report.pl 231 2008-03-25 14:43:57Z eddys $
+-require "getopts.pl";
+-&Getopts('c');
++use Getopt::Std;
++getopts('c');
+ if ($opt_c) { $do_recompile = 1; }
+
+ if ($ENV{'CC'} ne "") { $CC = $ENV{'CC'}; } else { $CC = "gcc"; }
+diff --git a/profmark/rocplot.pl b/profmark/rocplot.pl
+index d4c0f67..4e8175a 100755
+--- a/profmark/rocplot.pl
++++ b/profmark/rocplot.pl
+@@ -2,8 +2,8 @@
+
+ $nsearches = 1567;
+
+-require "getopts.pl";
+-&Getopts('n:X:x:');
++use Getopt::Std
++getopts('n:X:x:');
+
+ if ($opt_n) { $nsearches = $opt_n; }
+ if ($opt_X) {
diff --git a/sci-biology/hmmer/hmmer-2.3.2-r1.ebuild b/sci-biology/hmmer/hmmer-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..7b1fbba5e075
--- /dev/null
+++ b/sci-biology/hmmer/hmmer-2.3.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Sequence analysis using profile hidden Markov models"
+LICENSE="GPL-2"
+HOMEPAGE="http://hmmer.janelia.org/"
+SRC_URI="ftp://ftp.genetics.wustl.edu/pub/eddy/${PN}/${PV}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="pvm threads"
+KEYWORDS="~alpha amd64 ia64 ~ppc ~sparc x86"
+
+DEPEND="pvm? ( sys-cluster/pvm )"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix="${D}"/usr \
+ --exec_prefix="${D}"/usr \
+ --mandir="${D}"/usr/share/man \
+ --enable-lfs \
+ $(use_enable pvm) \
+ $(use_enable threads) || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ cd src
+ dolib libhmmer.a
+ insinto /usr/include/hmmer
+ doins *.h
+
+ cd ../squid
+ dobin afetch alistat compalign compstruct revcomp seqstat seqsplit sfetch shuffle sreformat sindex weight translate
+ dolib libsquid.a
+ insinto /usr/include/hmmer
+ doins *.h
+
+ cd ..
+ dodoc NOTES
+ newdoc 00README README
+ insinto /usr/share/doc/${PF}
+ doins Userguide.pdf
+}
+
+src_test() {
+ make check
+}
diff --git a/sci-biology/hmmer/hmmer-2.3.2-r2.ebuild b/sci-biology/hmmer/hmmer-2.3.2-r2.ebuild
new file mode 100644
index 000000000000..64fa50030079
--- /dev/null
+++ b/sci-biology/hmmer/hmmer-2.3.2-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Sequence analysis using profile hidden Markov models"
+LICENSE="GPL-2"
+HOMEPAGE="http://hmmer.janelia.org/"
+SRC_URI="ftp://ftp.genetics.wustl.edu/pub/eddy/${PN}/${PV}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="pvm threads"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ppc64 ~sparc x86"
+
+DEPEND="pvm? ( sys-cluster/pvm )"
+
+src_compile() {
+ econf \
+ --host=${CHOST} \
+ --prefix="${D}"/usr \
+ --exec_prefix="${D}"/usr \
+ --mandir="${D}"/usr/share/man \
+ --enable-lfs \
+ $(use_enable pvm) \
+ $(use_enable threads) || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ cd src
+ dolib libhmmer.a
+ insinto /usr/include/hmmer
+ doins *.h
+
+ cd ../squid
+ dobin afetch alistat compalign compstruct revcomp seqstat seqsplit sfetch shuffle sreformat sindex weight translate
+ dolib libsquid.a
+ insinto /usr/include/hmmer
+ doins *.h
+
+ cd ..
+ dodoc NOTES
+ newdoc 00README README
+ insinto /usr/share/doc/${PF}
+ doins Userguide.pdf
+}
+
+src_test() {
+ make check
+}
diff --git a/sci-biology/hmmer/hmmer-3.0.ebuild b/sci-biology/hmmer/hmmer-3.0.ebuild
new file mode 100644
index 000000000000..86183e7f9d3a
--- /dev/null
+++ b/sci-biology/hmmer/hmmer-3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Sequence analysis using profile hidden Markov models"
+HOMEPAGE="http://hmmer.janelia.org/"
+SRC_URI="ftp://selab.janelia.org/pub/software/hmmer3/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+cpu_flags_x86_sse mpi +threads gsl static-libs"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="
+ mpi? ( virtual/mpi )
+ gsl? ( >=sci-libs/gsl-1.12 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fix_tests.patch \
+ "${FILESDIR}"/${P}-perl-5.16-2.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable mpi) \
+ $(use_enable threads) \
+ $(use_with gsl)
+}
+
+src_install() {
+ default
+
+ use static-libs && dolib.a src/libhmmer.a easel/libeasel.a
+
+ insinto /usr/share/${PN}
+ doins -r tutorial
+ dodoc Userguide.pdf
+}
diff --git a/sci-biology/hmmer/metadata.xml b/sci-biology/hmmer/metadata.xml
new file mode 100644
index 000000000000..66fa76626615
--- /dev/null
+++ b/sci-biology/hmmer/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <use>
+ <flag name="pvm">Add support for parallel virtual machine
+ (<pkg>sys-cluster/pvm</pkg>)</flag>
+ </use>
+</pkgmetadata>