summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/maq')
-rw-r--r--sci-biology/maq/Manifest2
-rw-r--r--sci-biology/maq/files/maq-0.7.1-bfr-overfl.patch16
-rw-r--r--sci-biology/maq/files/maq-0.7.1-flags.patch24
-rw-r--r--sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch34
-rw-r--r--sci-biology/maq/maq-0.7.1-r1.ebuild40
-rw-r--r--sci-biology/maq/maq-0.7.1.ebuild24
-rw-r--r--sci-biology/maq/metadata.xml8
7 files changed, 148 insertions, 0 deletions
diff --git a/sci-biology/maq/Manifest b/sci-biology/maq/Manifest
new file mode 100644
index 000000000000..b5eb751fe292
--- /dev/null
+++ b/sci-biology/maq/Manifest
@@ -0,0 +1,2 @@
+DIST calib-36.dat.gz 196371 SHA256 d4480e04446eb273f1908add709dd5a24262c08a59a1647b9a2d053f4d30181b
+DIST maq-0.7.1.tar.bz2 368645 SHA256 e1671e0408b0895f5ab943839ee8f28747cf5f55dc64032c7469b133202b6de2
diff --git a/sci-biology/maq/files/maq-0.7.1-bfr-overfl.patch b/sci-biology/maq/files/maq-0.7.1-bfr-overfl.patch
new file mode 100644
index 000000000000..9f4247d441f5
--- /dev/null
+++ b/sci-biology/maq/files/maq-0.7.1-bfr-overfl.patch
@@ -0,0 +1,16 @@
+ simulate.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/simulate.c b/simulate.c
+index 788c440..67ba2ba 100644
+--- a/simulate.c
++++ b/simulate.c
+@@ -383,7 +383,7 @@ static void simustat_core(gzFile fp, int Q_thres)
+ memset(wc_single, 0, 40); memset(tot_single, 0, 40);
+ memset(wc_pair, 0, 40); memset(tot_pair, 0, 40);
+ memset(abpair, 0, 4 * 256 * 10);
+- memset(tc[2], 0, 4 * sizeof(int));
++ memset(tc, 0, 4 * sizeof(int));
+ while (maqmap_read1(fp, m1)) {
+ int is_correct;
+ bit32_t p1, p2;
diff --git a/sci-biology/maq/files/maq-0.7.1-flags.patch b/sci-biology/maq/files/maq-0.7.1-flags.patch
new file mode 100644
index 000000000000..721e53248b7a
--- /dev/null
+++ b/sci-biology/maq/files/maq-0.7.1-flags.patch
@@ -0,0 +1,24 @@
+ configure.ac | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index ad2f1e6..4f9d7be 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -8,6 +8,7 @@ AC_PROG_CXX
+
+ # set CFLAGS and CXXFLAGS
+ user_CFLAGS=${CFLAGS}
++user_CXXFLAGS=${CXXFLAGS}
+ generic_CFLAGS="-Wall"
+ ext_CFLAGS=""
+ case "${host_cpu}-${host_os}" in
+@@ -37,7 +38,7 @@ AC_ARG_ENABLE(shortread, [ --enable-shortreads use shortread mode],
+ AC_ARG_ENABLE(intel64, [ --enable-intel64 optimize for Intel64 CPU such as Xeon and Core2],
+ [ext_CFLAGS="${ext_CFLAGS} -mtune=nocona"], [])
+ CFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CFLAGS}"
+-CXXFLAGS=$CFLAGS
++CXXFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CXXFLAGS}"
+
+ AC_STDC_HEADERS
+ AC_CHECK_HEADER(zlib.h)
diff --git a/sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch b/sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch
new file mode 100644
index 000000000000..4b97da89be48
--- /dev/null
+++ b/sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch
@@ -0,0 +1,34 @@
+ stdhash.hh | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/stdhash.hh b/stdhash.hh
+index eaf98af..16cd1a3 100644
+--- a/stdhash.hh
++++ b/stdhash.hh
+@@ -412,7 +412,7 @@ public:
+ inline bool insert(const keytype_t &key) {
+ __lh3_hash_base_class<keytype_t>::rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
+ else ++(this->n_size); // then ret == 2
+@@ -493,7 +493,7 @@ public:
+ inline bool insert(const keytype_t &key, const valtype_t &val) {
+ rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ vals[i] = val;
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
+@@ -503,7 +503,7 @@ public:
+ inline bool insert(const keytype_t &key, valtype_t **q) {
+ rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ *q = vals + i;
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
diff --git a/sci-biology/maq/maq-0.7.1-r1.ebuild b/sci-biology/maq/maq-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..645a2d65a620
--- /dev/null
+++ b/sci-biology/maq/maq-0.7.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Mapping and Assembly with Qualities - mapping Solexa and SOLiD reads to reference sequences"
+HOMEPAGE="http://maq.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/calib-36.dat.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-bfr-overfl.patch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ sed \
+ -e '/ext_CFLAGS/s:-m64::g' \
+ -i configure* || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ insinto /usr/share/maq
+ doins "${WORKDIR}"/*.dat
+ doman maq.1
+ dodoc ${PN}.pdf
+}
diff --git a/sci-biology/maq/maq-0.7.1.ebuild b/sci-biology/maq/maq-0.7.1.ebuild
new file mode 100644
index 000000000000..1089eefbae04
--- /dev/null
+++ b/sci-biology/maq/maq-0.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Mapping and Assembly with Qualities - mapping Solexa and SOLiD reads to reference sequences"
+HOMEPAGE="http://maq.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/calib-36.dat.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ insinto /usr/share/maq
+ doins "${WORKDIR}"/*.dat || die
+ doman maq.1
+ dodoc AUTHORS ChangeLog NEWS maq.pdf
+}
diff --git a/sci-biology/maq/metadata.xml b/sci-biology/maq/metadata.xml
new file mode 100644
index 000000000000..79ebcc09421b
--- /dev/null
+++ b/sci-biology/maq/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <upstream>
+ <remote-id type="sourceforge">maq</remote-id>
+ </upstream>
+</pkgmetadata>