summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/paml/paml-4.9j.ebuild')
-rw-r--r--sci-biology/paml/paml-4.9j.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/paml/paml-4.9j.ebuild b/sci-biology/paml/paml-4.9j.ebuild
new file mode 100644
index 000000000000..e8a5d07ee40c
--- /dev/null
+++ b/sci-biology/paml/paml-4.9j.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Phylogenetic Analysis by Maximum Likelihood"
+HOMEPAGE="http://abacus.gene.ucl.ac.uk/software/paml.html"
+SRC_URI="http://abacus.gene.ucl.ac.uk/software/${P/-/}.tgz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${P/-/}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.9j-makefile.patch
+ "${FILESDIR}"/${PN}-4.9j-fno-common.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_install() {
+ dobin src/{baseml,basemlg,codeml,evolver,pamp,mcmctree,infinitesites,yn00,chi2}
+
+ dodoc -r README.txt doc/.
+
+ insinto /usr/share/${PN}/control
+ doins *.ctl
+
+ insinto /usr/share/${PN}/dat
+ doins -r stewart* *.dat dat/.
+
+ insinto /usr/share/${PN}
+ doins -r examples
+}