summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/poa/poa-2-r1.ebuild')
-rw-r--r--sci-biology/poa/poa-2-r1.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/sci-biology/poa/poa-2-r1.ebuild b/sci-biology/poa/poa-2-r1.ebuild
index 126272f06c60..d87f2a638117 100644
--- a/sci-biology/poa/poa-2-r1.ebuild
+++ b/sci-biology/poa/poa-2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_P="${PN}V${PV}"
@@ -15,31 +15,30 @@ SRC_URI="mirror://sourceforge/poamsa/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
S="${WORKDIR}/${MY_P}"
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-respect-flags.patch
- epatch "${FILESDIR}"/${P}-fno-common.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-flags.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_configure() {
+ tc-export AR CC RANLIB
}
src_compile() {
- emake \
- CC="$(tc-getCC)" \
- OPT_CFLAGS="${CFLAGS}" \
- poa
+ emake poa
}
src_install() {
- dobin "${S}"/poa "${S}"/make_pscores.pl
- use static-libs && dolib.a "${S}"/liblpo.a
- dodoc "${S}"/README "${S}"/multidom.*
+ dobin poa make_pscores.pl
+ dodoc README multidom.*
insinto /usr/share/poa
- doins "${S}"/*.mat
+ doins *.mat
}
pkg_postinst() {
elog "poa requires a score matrix as the first argument."
- elog "This package installs two examples to ${EROOT}usr/share/poa/."
+ elog "This package installs two examples to ${EROOT}/usr/share/poa/."
}