summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild')
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
index 8e2a07f8183e..06fc28376ff5 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -18,14 +18,10 @@ RESTRICT="test"
DEPEND="mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-impl-dec.patch )
-
-pkg_setup() {
- use mpi && [[ $(tc-getCC) == icc* ]] &&
- die "The parallelized version of tree-puzzle cannot be compiled using icc.
- Either disable the \"mpi\" USE flag to compile only the non-parallelized
- version of the program, or use gcc as your compiler (CC=\"gcc\")."
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-impl-dec.patch
+ "${FILESDIR}"/${P}-MPI-3.0.patch
+)
src_configure() {
default
@@ -38,9 +34,14 @@ src_configure() {
fi
}
+src_compile() {
+ # hopelessly terrible build system, abuses Automake
+ emake -j1
+}
+
src_install() {
- dobin src/puzzle
- use mpi && dobin src/ppuzzle
+ dobin src/puzzle $(usev mpi src/ppuzzle)
+
einstalldocs
# User manual