summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/allpathslg/allpathslg-52488-r2.ebuild5
-rw-r--r--sci-biology/allpathslg/files/allpathslg-52488-gcc7.patch13
2 files changed, 16 insertions, 2 deletions
diff --git a/sci-biology/allpathslg/allpathslg-52488-r2.ebuild b/sci-biology/allpathslg/allpathslg-52488-r2.ebuild
index e68430e2462d..391575f4f057 100644
--- a/sci-biology/allpathslg/allpathslg-52488-r2.ebuild
+++ b/sci-biology/allpathslg/allpathslg-52488-r2.ebuild
@@ -23,8 +23,9 @@ DEPEND="
dev-libs/boost:="
PATCHES=(
- "${WORKDIR}/${P}-patchset/${P}_fix-buildsystem.patch"
- "${WORKDIR}/${P}-patchset/${P}_remove-namespace-std.patch"
+ "${WORKDIR}"/${P}-patchset/${P}_fix-buildsystem.patch
+ "${WORKDIR}"/${P}-patchset/${P}_remove-namespace-std.patch
+ "${FILESDIR}"/${P}-gcc7.patch
)
pkg_pretend() {
diff --git a/sci-biology/allpathslg/files/allpathslg-52488-gcc7.patch b/sci-biology/allpathslg/files/allpathslg-52488-gcc7.patch
new file mode 100644
index 000000000000..7c5e1267e4e9
--- /dev/null
+++ b/sci-biology/allpathslg/files/allpathslg-52488-gcc7.patch
@@ -0,0 +1,13 @@
+--- a/src/paths/long/VariantCallTools.cc
++++ b/src/paths/long/VariantCallTools.cc
+@@ -1870,8 +1870,8 @@
+ bool i_is_indel = (change[i].first.size() != change[i].second.size());
+ if (i_is_indel) inserted_base += change[i].second.size()-1;
+ size_t j = i + 1;
+- while (j < edits.size() && abs(edits[j].second - edits[j-1].second
+- - change[j-1].first.size()) < MinClumpSep) {
++ while (j < edits.size() && std::abs(edits[j].second - edits[j-1].second
++ - static_cast<int>(change[j-1].first.size())) < MinClumpSep) {
+ nmatch += edits[j].second - edits[j-1].second - change[j-1].first.size();
+ bool j_is_indel = (change[j].first.size() != change[j].second.size());
+ if (j_is_indel)